qspi-ubifs-image_0.1.bb 2.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. SUMMARY = "QSPI Ubifs Image Creator"
  2. DESCRIPTION = "Recipe to create a QSPI Ubifs Image"
  3. LICENSE = "CLOSED"
  4. inherit core-image
  5. DEPENDS += "opensbi deploy-bootfiles quilt quilt-native"
  6. LIC_FILES_CHKSUM = ""
  7. IMAGE_FSTYPES = "ubi ubifs qspi_ubifs"
  8. MKUBIFS_ARGS = "-m 1 -e 65408 -c 26876"
  9. UBINIZE_ARGS = " -p 64KiB -m 1"
  10. IMAGE_ROOTFS_SIZE ?= "8192"
  11. IMAGE_FEATURES += "allow-empty-password empty-root-password"
  12. #IMAGE_INSTALL += "mtd-utils mtd-utils-ubifs kernel-modules"
  13. IMAGE_INSTALL += "helloworld"
  14. IMAGE_FEATURES:remove = "dbg-pkgs"
  15. export IMAGE_BASENAME = "qspi-ubifs"
  16. do_image_qspi_ubifs[depends] += " \
  17. deploy-bootfiles:do_deploy \
  18. opensbi:do_deploy \
  19. virtual/kernel:do_deploy \
  20. "
  21. IMAGE_TYPEDEP:qspi_ubifs = "ubi"
  22. IMAGE_CMD:qspi_ubifs () {
  23. dd if=${DEPLOY_DIR_IMAGE}/bootcode.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ubifs-image.bin bs=32 seek=0 count=128
  24. dd if=${DEPLOY_DIR_IMAGE}/bootjump.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ubifs-image.bin bs=32 seek=128 count=1
  25. dd if=${DEPLOY_DIR_IMAGE}/dubhe90_fpga_ubi.dtb of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ubifs-image.bin bs=32 seek=129 count=255
  26. dd if=${DEPLOY_DIR_IMAGE}/fw_payload.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ubifs-image.bin bs=32 seek=384 count=1048192
  27. dd if=${IMGDEPLOYDIR}/qspi-ubifs-starfive-dubhe.ubi of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ubifs-image.bin bs=64KiB seek=512
  28. dd if=${DEPLOY_DIR_IMAGE}/bootcode.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ubifs-image.bin bs=32 seek=0 count=128
  29. dd if=${DEPLOY_DIR_IMAGE}/bootjump.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ubifs-image.bin bs=32 seek=128 count=1
  30. dd if=${DEPLOY_DIR_IMAGE}/dubhe80_fpga_ubi.dtb of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ubifs-image.bin bs=32 seek=129 count=255
  31. dd if=${DEPLOY_DIR_IMAGE}/fw_payload.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ubifs-image.bin bs=32 seek=384 count=1048192
  32. dd if=${IMGDEPLOYDIR}/qspi-ubifs-starfive-dubhe.ubi of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ubifs-image.bin bs=64KiB seek=512
  33. }