dubhe-image-initramfs.bb 1.2 KB

12345678910111213141516171819202122232425262728293031323334
  1. # Simple initramfs image. Mostly used for live images.
  2. DESCRIPTION = "Small image capable of booting a device. The kernel includes \
  3. the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
  4. first 'init' program more efficiently."
  5. INITRAMFS_SCRIPTS ?= "\
  6. initramfs-boot packagegroup-core-boot \
  7. "
  8. PACKAGE_INSTALL = "${INITRAMFS_SCRIPTS} ${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} helloworld coremark dhrystone perf gdb gdbserver util-linux ethtool atftp iperf3 openssh dhcpcd kvmtool tmux"
  9. # Do not pollute the initrd image with rootfs features
  10. IMAGE_FEATURES = ""
  11. export IMAGE_BASENAME = "dubhe-image-initramfs"
  12. IMAGE_NAME_SUFFIX ?= ""
  13. IMAGE_LINGUAS = "en-us"
  14. GLIBC_GENERATE_LOCALES = "en_US.UTF-8"
  15. LICENSE = "MIT"
  16. IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
  17. inherit core-image
  18. IMAGE_ROOTFS_SIZE = "8192"
  19. IMAGE_ROOTFS_EXTRA_SPACE = "0"
  20. EXTRA_IMAGEDEPENDS ?= ""
  21. # Use the same restriction as initramfs-module-install
  22. COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*|riscv64.*|rv64.*)-(linux.*|freebsd.*)'
  23. # Override this as the qspi-image will populate the sdk_ext
  24. do_populate_sdk_ext () {
  25. }