opensbi_%.bbappend 1.5 KB

12345678910111213141516171819202122232425
  1. SRCREV:starfive-visionfive2 = "c6a092cd80112529cb2e92e180767ff5341b22a3"
  2. SRC_URI:starfive-visionfive2 = "git://github.com/starfive-tech/opensbi.git;protocol=https \
  3. file://visionfive2-uboot-fit-image.its \
  4. "
  5. SRCREV:starfive-jh8100 = "06c3d05b7f5f1e0aa24141e4de487313b620cea9"
  6. SRC_URI:starfive-jh8100 = "git://git@192.168.110.45/starfive-tech/opensbi.git;protocol=ssh;branch=fpga-starfive-v1.2-jh8100"
  7. EXTRA_OEMAKE:starfive-visionfive2 += "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= FW_TEXT_START=0x40000000"
  8. EXTRA_OEMAKE:starfive-jh8100 += "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= FW_OPTIONS=0 FW_TEXT_START=0x40000000 PLATFORM_DEFCONFIG=starfive_defconfig"
  9. DEPENDS:starfive-visionfive2:append = " u-boot-tools-native dtc-native"
  10. do_deploy:append:starfive-visionfive2() {
  11. install -m 0644 ${WORKDIR}/visionfive2-uboot-fit-image.its ${DEPLOYDIR}/visionfive2-uboot-fit-image.its
  12. cd ${DEPLOYDIR}
  13. mkimage -f visionfive2-uboot-fit-image.its -A riscv -O u-boot -T firmware visionfive2_fw_payload.img
  14. }
  15. do_deploy:append:starfive-dubhe(){
  16. oe_runmake clean
  17. oe_runmake PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= PLATFORM_DEFCONFIG=starfive_defconfig FW_PAYLOAD_PATH=${DEPLOY_DIR_IMAGE}/Image-initramfs-starfive-dubhe.bin
  18. install -m 755 ${B}/build/platform/generic/firmware/fw_payload.bin ${DEPLOYDIR}/fw_payload_initramfs.bin
  19. install -m 755 ${B}/build/platform/generic/firmware/fw_payload.elf ${DEPLOYDIR}/fw_payload_initramfs.elf
  20. }