opensbi_1.1.bb 2.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. SUMMARY = "RISC-V Open Source Supervisor Binary Interface (OpenSBI)"
  2. DESCRIPTION = "OpenSBI aims to provide an open-source and extensible implementation of the RISC-V SBI specification for a platform specific firmware (M-mode) and a general purpose OS, hypervisor or bootloader (S-mode or HS-mode). OpenSBI implementation can be easily extended by RISC-V platform or System-on-Chip vendors to fit a particular hadware configuration."
  3. HOMEPAGE = "https://github.com/riscv/opensbi"
  4. LICENSE = "BSD-2-Clause"
  5. LIC_FILES_CHKSUM = "file://COPYING.BSD;md5=42dd9555eb177f35150cf9aa240b61e5"
  6. require opensbi-payloads.inc
  7. inherit autotools-brokensep deploy
  8. SRCREV = "bee8253d8f04c56017860386d1b2132cf4f4b7c5"
  9. SRC_URI = "git://git@192.168.110.45/starfive-tech/opensbi.git;protocol=ssh;branch=starfive-v1.1-dubhe"
  10. SRC_URI:remove:nezha = " \
  11. file://0001-lib-utils-fdt-Require-match-data-to-be-const.patch \
  12. file://0002-lib-utils-timer-Add-a-separate-compatible-for-the-D1.patch \
  13. "
  14. S = "${WORKDIR}/git"
  15. EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= "
  16. # If RISCV_SBI_PAYLOAD is set then include it as a payload
  17. EXTRA_OEMAKE:append = " ${@riscv_get_extra_oemake_image(d)}"
  18. EXTRA_OEMAKE:append = " ${@riscv_get_extra_oemake_fdt(d)}"
  19. # Required if specifying a custom payload
  20. do_compile[depends] += "${@riscv_get_do_compile_depends(d)}"
  21. do_install:append() {
  22. # In the future these might be required as a dependency for other packages.
  23. # At the moment just delete them to avoid warnings
  24. rm -r ${D}/include
  25. rm -r ${D}/lib*
  26. rm -r ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/payloads
  27. }
  28. do_deploy () {
  29. install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_payload.* ${DEPLOYDIR}/
  30. install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_jump.* ${DEPLOYDIR}/
  31. install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_dynamic.* ${DEPLOYDIR}/
  32. }
  33. addtask deploy before do_build after do_install
  34. FILES:${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_jump.*"
  35. FILES:${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_payload.*"
  36. FILES:${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_dynamic.*"
  37. COMPATIBLE_HOST = "(riscv64|riscv32).*"
  38. INHIBIT_PACKAGE_STRIP = "1"
  39. SECURITY_CFLAGS = ""