dubhe-image-initramfs.bb 1.1 KB

123456789101112131415161718192021222324252627282930313233
  1. # Simple initramfs image. Mostly used for live images.
  2. DESCRIPTION = "Small image capable of booting a device. The kernel includes \
  3. the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
  4. first 'init' program more efficiently."
  5. INITRAMFS_SCRIPTS ?= "\
  6. initramfs-boot packagegroup-core-boot \
  7. "
  8. PACKAGE_INSTALL = "${INITRAMFS_SCRIPTS} ${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} helloworld coremark dhrystone perf gdb gdbserver "
  9. # Do not pollute the initrd image with rootfs features
  10. IMAGE_FEATURES = ""
  11. export IMAGE_BASENAME = "dubhe-image-initramfs"
  12. IMAGE_NAME_SUFFIX ?= ""
  13. IMAGE_LINGUAS = ""
  14. LICENSE = "MIT"
  15. IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
  16. inherit core-image
  17. IMAGE_ROOTFS_SIZE = "8192"
  18. IMAGE_ROOTFS_EXTRA_SPACE = "0"
  19. EXTRA_IMAGEDEPENDS ?= ""
  20. # Use the same restriction as initramfs-module-install
  21. COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*|riscv64.*|rv64.*)-(linux.*|freebsd.*)'
  22. # Override this as the qspi-image will populate the sdk_ext
  23. do_populate_sdk_ext () {
  24. }