helloworld_0.1.bb 327 B

12345678910111213141516171819
  1. SUMMARY = "Hello World recipe"
  2. DESCRIPTION = "Sample helloworld recipe"
  3. LICENSE = "CLOSED"
  4. LIC_FILES_CHKSUM = ""
  5. SRC_URI = "file://helloworld.c \
  6. "
  7. S = "${WORKDIR}"
  8. do_compile(){
  9. ${CC} ${CFLAGS} ${LDFLAGS} helloworld.c -o helloworld
  10. }
  11. do_install(){
  12. install -d ${D}${bindir}
  13. install -m 0755 helloworld ${D}${bindir}
  14. }