gdb_10.1.bb 945 B

12345678910111213141516171819202122232425262728
  1. require gdb.inc
  2. require gdb-${PV}.inc
  3. inherit python3-dir
  4. EXTRA_OEMAKE:append:libc-musl = "\
  5. gt_cv_func_gnugettext1_libc=yes \
  6. gt_cv_func_gnugettext2_libc=yes \
  7. gl_cv_func_working_strerror=yes \
  8. gl_cv_func_strerror_0_works=yes \
  9. gl_cv_func_gettimeofday_clobber=no \
  10. "
  11. do_configure:prepend() {
  12. if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
  13. cat > ${WORKDIR}/python << EOF
  14. #!/bin/sh
  15. case "\$2" in
  16. --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;;
  17. --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;;
  18. --exec-prefix) echo "${exec_prefix}" ;;
  19. *) exit 1 ;;
  20. esac
  21. exit 0
  22. EOF
  23. chmod +x ${WORKDIR}/python
  24. fi
  25. }