dubhe-image-initramfs.bb 1.2 KB

1234567891011121314151617181920212223242526272829303132333435
  1. # Simple initramfs image. Mostly used for live images.
  2. DESCRIPTION = "Small image capable of booting a device. The kernel includes \
  3. the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
  4. first 'init' program more efficiently."
  5. INITRAMFS_SCRIPTS ?= "\
  6. initramfs-boot packagegroup-core-boot \
  7. "
  8. PACKAGE_INSTALL = "${INITRAMFS_SCRIPTS} ${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} helloworld coremark dhrystone perf gdb gdbserver util-linux ethtool atftp iperf3 openssh dhcpcd kvmtool tmux"
  9. # Do not pollute the initrd image with rootfs features
  10. IMAGE_FEATURES = ""
  11. export IMAGE_BASENAME = "dubhe-image-initramfs"
  12. IMAGE_NAME_SUFFIX ?= ""
  13. #IMAGE_LINGUAS = ""
  14. IMAGE_LINGUAS = "en-us"
  15. GLIBC_GENERATE_LOCALES = "en_US.UTF-8"
  16. LICENSE = "MIT"
  17. IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
  18. inherit core-image
  19. IMAGE_ROOTFS_SIZE = "8192"
  20. IMAGE_ROOTFS_EXTRA_SPACE = "0"
  21. EXTRA_IMAGEDEPENDS ?= ""
  22. # Use the same restriction as initramfs-module-install
  23. COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*|riscv64.*|rv64.*)-(linux.*|freebsd.*)'
  24. # Override this as the qspi-image will populate the sdk_ext
  25. do_populate_sdk_ext () {
  26. }