dhrystone_2.1.bb 637 B

1234567891011121314151617181920212223242526
  1. SUMMARY = "Dhrystone CPU benchmark"
  2. LICENSE = "PD"
  3. LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/PD;md5=b3597d12946881e13cb3b548d1173851"
  4. INHIBIT_PACKAGE_STRIP = "1"
  5. BRANCH = "master"
  6. SRC_URI = "git://github.com/sifive/benchmark-dhrystone.git;protocol=ssh;branch=${BRANCH} \
  7. file://0001-dhrystone-Edit-compiler-flags.patch \
  8. "
  9. SRCREV = "0ddff533cc9052c524990d5ace4560372053314b"
  10. S = "${WORKDIR}/git"
  11. TARGET_CC_ARCH += "${LDFLAGS}"
  12. EXTRA_OEMAKE += "'CC=${CC}'"
  13. do_compile(){
  14. oe_runmake dhrystone
  15. }
  16. do_install() {
  17. install -d ${D}${bindir}
  18. install -m 0755 dhrystone ${D}${bindir}
  19. }