coremark_1.0.bb 681 B

1234567891011121314151617181920212223242526
  1. SUMMARY = "Coremark CPU benchmark"
  2. LICENSE = "Apache-2.0"
  3. LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
  4. INHIBIT_PACKAGE_STRIP = "1"
  5. BRANCH = "master"
  6. SRC_URI = "git://github.com/sifive/benchmark-coremark.git;protocol=ssh;branch=${BRANCH} \
  7. file://0001-Add-Compiler-Flags-and-remove-exe-from-output.patch \
  8. "
  9. SRCREV = "4486de1f0afe9d6c1fa8dd63743e5751286f3d2f"
  10. S = "${WORKDIR}/git"
  11. TARGET_CC_ARCH += "${LDFLAGS}"
  12. EXTRA_OEMAKE += "'CC=${CC}' PORT_DIR=linux64"
  13. do_compile(){
  14. oe_runmake compile
  15. }
  16. do_install() {
  17. install -d ${D}${bindir}
  18. install -m 0755 coremark ${D}${bindir}
  19. }