openocd_riscv.bbappend 1.1 KB

1234567891011121314151617181920212223242526272829
  1. FILESEXTRAPATHS:prepend := "${THISDIR}/openocd:"
  2. LIC_FILES_CHKSUM = "file://COPYING;md5=599d2d1ee7fc84c0467b3d19801db870"
  3. PV = "riscv22"
  4. SRC_URI = " \
  5. git://github.com/riscv/riscv-openocd.git;protocol=https;branch=riscv;name=openocd \
  6. git://repo.or.cz/r/git2cl.git;protocol=http;destsuffix=tools/git2cl;name=git2cl;branch=master \
  7. git://github.com/msteveb/jimtcl.git;protocol=https;branch=master;name=jimtcl;destsuffix=git/jimtcl \
  8. git://repo.or.cz/r/libjaylink.git;protocol=http;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink;branch=master \
  9. file://Dubhe_FPGA_openocd.patch \
  10. file://olimex-openocd_s5.cfg \
  11. file://olimex_flash_write.cfg \
  12. file://0001-autosetup-cc-check-tools-check-only-the-name.patch \
  13. "
  14. SRCREV_openocd = "a037b20f2e015859327ab37588792386c4fc942f"
  15. SRCREV_jimtcl = "70b007b63669a709b0e8aef34a22658047815cc2"
  16. EXTRA_OECONF = "--enable-ftdi"
  17. inherit deploy
  18. do_deploy(){
  19. install -m 755 ${WORKDIR}/olimex-openocd_s5.cfg ${DEPLOYDIR}/
  20. install -m 755 ${WORKDIR}/olimex_flash_write.cfg ${DEPLOYDIR}/
  21. }
  22. addtask deploy before do_build after do_install