qemu_6.0.0.bb 9.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143
  1. BBCLASSEXTEND = "nativesdk"
  2. require qemu.inc
  3. # error: a parameter list without types is only allowed in a function definition
  4. # void (*_function)(sigval_t);
  5. COMPATIBLE_HOST:libc-musl = 'null'
  6. DEPENDS = "glib-2.0 zlib pixman bison-native ninja-native meson-native"
  7. RDEPENDS:${PN}:class-target += "bash"
  8. EXTRA_OECONF:append:class-target = " --target-list=${@get_qemu_target_list(d)}"
  9. EXTRA_OECONF:append:class-target:mipsarcho32 = "${@bb.utils.contains('BBEXTENDCURR', 'multilib', ' --disable-capstone', '', d)}"
  10. EXTRA_OECONF:append:class-nativesdk = " --target-list=${@get_qemu_target_list(d)}"
  11. do_install:append:class-nativesdk() {
  12. ${@bb.utils.contains('PACKAGECONFIG', 'gtk+', 'make_qemu_wrapper', '', d)}
  13. }
  14. PACKAGECONFIG ??= " \
  15. fdt sdl kvm pie \
  16. ${@bb.utils.filter('DISTRO_FEATURES', 'alsa xen', d)} \
  17. ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'virglrenderer glx', '', d)} \
  18. ${@bb.utils.filter('DISTRO_FEATURES', 'seccomp', d)} \
  19. "
  20. PACKAGECONFIG:class-nativesdk ??= "fdt sdl kvm pie \
  21. ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'virglrenderer glx', '', d)} \
  22. "
  23. FILESEXTRAPATHS:prepend := "${THISDIR}/qemu:"
  24. SRC_URI += "file://0001-softfloat-add-APIs-to-handle-alternative-sNaN-propag.patch \
  25. file://0002-target-riscv-change-the-api-for-single-double-fmin-f.patch \
  26. file://0003-target-riscv-support-x-Zfh-in-cpu-option.patch \
  27. file://0004-target-riscv-Implement-zfh-extension.patch \
  28. file://0005-target-riscv-fix-TB_FLAGS-bits-overlapping-bug-for-r.patch \
  29. file://0006-fpu-softfloat-set-invalid-excp-flag-for-RISC-V-mulad.patch \
  30. file://0007-target-riscv-Fixup-saturate-subtract-function.patch \
  31. file://0008-target-riscv-fix-vrgather-macro-index-variable-type-.patch \
  32. file://0009-target-riscv-drop-vector-0.7.1-and-add-1.0-support.patch \
  33. file://0010-target-riscv-Use-FIELD_EX32-to-extract-wd-field.patch \
  34. file://0011-target-riscv-rvv-1.0-add-mstatus-VS-field.patch \
  35. file://0012-target-riscv-rvv-1.0-add-sstatus-VS-field.patch \
  36. file://0013-target-riscv-rvv-1.0-introduce-writable-misa.v-field.patch \
  37. file://0014-target-riscv-rvv-1.0-add-translation-time-vector-con.patch \
  38. file://0015-target-riscv-rvv-1.0-remove-rvv-related-codes-from-f.patch \
  39. file://0016-target-riscv-rvv-1.0-add-vcsr-register.patch \
  40. file://0017-target-riscv-rvv-1.0-add-vlenb-register.patch \
  41. file://0018-target-riscv-rvv-1.0-check-MSTATUS_VS-when-accessing.patch \
  42. file://0019-target-riscv-rvv-1.0-remove-MLEN-calculations.patch \
  43. file://0020-target-riscv-rvv-1.0-add-fractional-LMUL.patch \
  44. file://0021-target-riscv-rvv-1.0-add-VMA-and-VTA.patch \
  45. file://0022-target-riscv-rvv-1.0-update-check-functions.patch \
  46. file://0023-target-riscv-introduce-more-imm-value-modes-in-trans.patch \
  47. file://0024-target-riscv-rvv-1.0-add-translation-time-nan-box-he.patch \
  48. file://0025-target-riscv-rvv-1.0-configure-instructions.patch \
  49. file://0026-target-riscv-rvv-1.0-stride-load-and-store-instructi.patch \
  50. file://0027-target-riscv-rvv-1.0-index-load-and-store-instructio.patch \
  51. file://0028-target-riscv-rvv-1.0-fix-address-index-overflow-bug-.patch \
  52. file://0029-target-riscv-rvv-1.0-fault-only-first-unit-stride-lo.patch \
  53. file://0030-target-riscv-rvv-1.0-amo-operations.patch \
  54. file://0031-target-riscv-rvv-1.0-load-store-whole-register-instr.patch \
  55. file://0032-target-riscv-rvv-1.0-update-vext_max_elems-for-load-.patch \
  56. file://0033-target-riscv-rvv-1.0-take-fractional-LMUL-into-vecto.patch \
  57. file://0034-target-riscv-rvv-1.0-floating-point-square-root-inst.patch \
  58. file://0035-target-riscv-rvv-1.0-floating-point-classify-instruc.patch \
  59. file://0036-target-riscv-rvv-1.0-mask-population-count-instructi.patch \
  60. file://0037-target-riscv-rvv-1.0-find-first-set-mask-bit-instruc.patch \
  61. file://0038-target-riscv-rvv-1.0-set-X-first-mask-bit-instructio.patch \
  62. file://0039-target-riscv-rvv-1.0-iota-instruction.patch \
  63. file://0040-target-riscv-rvv-1.0-element-index-instruction.patch \
  64. file://0041-target-riscv-rvv-1.0-allow-load-element-with-sign-ex.patch \
  65. file://0042-target-riscv-rvv-1.0-register-gather-instructions.patch \
  66. file://0043-target-riscv-rvv-1.0-integer-scalar-move-instruction.patch \
  67. file://0044-target-riscv-rvv-1.0-floating-point-move-instruction.patch \
  68. file://0045-target-riscv-rvv-1.0-floating-point-scalar-move-inst.patch \
  69. file://0046-target-riscv-rvv-1.0-whole-register-move-instruction.patch \
  70. file://0047-target-riscv-rvv-1.0-integer-extension-instructions.patch \
  71. file://0048-target-riscv-rvv-1.0-single-width-averaging-add-and-.patch \
  72. file://0049-target-riscv-rvv-1.0-single-width-bit-shift-instruct.patch \
  73. file://0050-target-riscv-rvv-1.0-integer-add-with-carry-subtract.patch \
  74. file://0051-target-riscv-rvv-1.0-narrowing-integer-right-shift-i.patch \
  75. file://0052-target-riscv-rvv-1.0-widening-integer-multiply-add-i.patch \
  76. file://0053-target-riscv-rvv-1.0-single-width-saturating-add-and.patch \
  77. file://0054-target-riscv-rvv-1.0-integer-comparison-instructions.patch \
  78. file://0055-target-riscv-rvv-1.0-floating-point-compare-instruct.patch \
  79. file://0056-target-riscv-rvv-1.0-mask-register-logical-instructi.patch \
  80. file://0057-target-riscv-rvv-1.0-slide-instructions.patch \
  81. file://0058-target-riscv-rvv-1.0-floating-point-slide-instructio.patch \
  82. file://0059-target-riscv-rvv-1.0-narrowing-fixed-point-clip-inst.patch \
  83. file://0060-target-riscv-rvv-1.0-single-width-floating-point-red.patch \
  84. file://0061-target-riscv-rvv-1.0-widening-floating-point-reducti.patch \
  85. file://0062-target-riscv-rvv-1.0-single-width-scaling-shift-inst.patch \
  86. file://0063-target-riscv-rvv-1.0-remove-widening-saturating-scal.patch \
  87. file://0064-target-riscv-rvv-1.0-remove-vmford.vv-and-vmford.vf.patch \
  88. file://0065-target-riscv-rvv-1.0-remove-integer-extract-instruct.patch \
  89. file://0066-target-riscv-rvv-1.0-floating-point-min-max-instruct.patch \
  90. file://0067-target-riscv-introduce-floating-point-rounding-mode-.patch \
  91. file://0068-target-riscv-rvv-1.0-floating-point-integer-type-con.patch \
  92. file://0069-target-riscv-rvv-1.0-widening-floating-point-integer.patch \
  93. file://0070-target-riscv-add-set-round-to-odd-rounding-mode-help.patch \
  94. file://0071-target-riscv-rvv-1.0-narrowing-floating-point-intege.patch \
  95. file://0072-target-riscv-rvv-1.0-relax-RV_VLEN_MAX-to-1024-bits.patch \
  96. file://0073-target-riscv-rvv-1.0-implement-vstart-CSR.patch \
  97. file://0074-target-riscv-rvv-1.0-trigger-illegal-instruction-exc.patch \
  98. file://0075-target-riscv-rvv-1.0-set-mstatus.SD-bit-when-writing.patch \
  99. file://0076-target-riscv-gdb-support-vector-registers-for-rv64-r.patch \
  100. file://0077-target-riscv-rvv-1.0-floating-point-reciprocal-squar.patch \
  101. file://0078-target-riscv-rvv-1.0-floating-point-reciprocal-estim.patch \
  102. file://0079-target-riscv-set-mstatus.SD-bit-when-writing-fp-CSRs.patch \
  103. file://0080-target-riscv-rvv-1.0-rename-r2_zimm-to-r2_zimm11.patch \
  104. file://0081-target-riscv-rvv-1.0-add-vsetivli-instruction.patch \
  105. file://0082-target-riscv-rvv-1.0-add-evl-parameter-to-vext_ldst_.patch \
  106. file://0083-target-riscv-rvv-1.0-add-vector-unit-stride-mask-loa.patch \
  107. file://0084-target-riscv-rvv-1.0-patch-floating-point-reduction-.patch \
  108. file://0085-target-riscv-reformat-sh-format-encoding-for-B-exten.patch \
  109. file://0086-target-riscv-rvb-count-leading-trailing-zeros.patch \
  110. file://0087-target-riscv-rvb-count-bits-set.patch \
  111. file://0088-target-riscv-rvb-logic-with-negate.patch \
  112. file://0089-target-riscv-rvb-pack-two-words-into-one-register.patch \
  113. file://0090-target-riscv-rvb-min-max-instructions.patch \
  114. file://0091-target-riscv-rvb-sign-extend-instructions.patch \
  115. file://0092-target-riscv-add-gen_shifti-and-gen_shiftiw-helper-f.patch \
  116. file://0093-target-riscv-rvb-single-bit-instructions.patch \
  117. file://0094-target-riscv-rvb-shift-ones.patch \
  118. file://0095-target-riscv-rvb-rotate-left-right.patch \
  119. file://0096-target-riscv-rvb-generalized-reverse.patch \
  120. file://0097-target-riscv-rvb-generalized-or-combine.patch \
  121. file://0098-target-riscv-rvb-address-calculation.patch \
  122. file://0099-target-riscv-rvb-add-shift-with-prefix-zero-extend.patch \
  123. file://0100-target-riscv-rvb-support-and-turn-on-B-extension-fro.patch \
  124. file://0101-target-riscv-rvb-add-b-ext-version-cpu-option.patch \
  125. file://0102-target-riscv-fix-REQUIRE_ZFH-macro-bug.patch \
  126. file://0103-linux-user-elfload-Implement-ELF_HWCAP-for-RISC-V.patch \
  127. file://0104-target-riscv-Pass-the-same-value-to-oprsz-and-maxsz.patch \
  128. file://0105-target-riscv-Backup-restore-mstatus.SD-bit-when-virt.patch \
  129. file://0106-target-riscv-Force-to-set-mstatus_hs.-SD-FS-bits-in-.patch \
  130. file://0107-target-riscv-Force-to-set-mstatus_hs.-SD-VS-bits-in-.patch \
  131. file://0001-merge-riscv-bitmapip-b0p94-version.patch \
  132. file://0002-Add-four-cache-csr-instruction.patch \
  133. file://0003-Fix-cache-instruction-bug.patch \
  134. "