qemu-helper-native_1.0.bb 649 B

1234567891011121314151617181920212223242526272829
  1. SUMMARY = "Helper utilities needed by the runqemu script"
  2. LICENSE = "GPLv2"
  3. RDEPENDS:${PN} = "qemu-system-native"
  4. PR = "r1"
  5. LIC_FILES_CHKSUM = "file://${WORKDIR}/tunctl.c;endline=4;md5=ff3a09996bc5fff6bc5d4e0b4c28f999"
  6. SRC_URI = "\
  7. file://tunctl.c \
  8. file://qemu-oe-bridge-helper \
  9. "
  10. S = "${WORKDIR}"
  11. inherit native
  12. do_compile() {
  13. ${CC} ${CFLAGS} ${LDFLAGS} -Wall tunctl.c -o tunctl
  14. }
  15. do_install() {
  16. install -d ${D}${bindir}
  17. install tunctl ${D}${bindir}/
  18. install -m 755 ${WORKDIR}/qemu-oe-bridge-helper ${D}${bindir}/
  19. }
  20. DEPENDS += "qemu-system-native"
  21. addtask addto_recipe_sysroot after do_populate_sysroot before do_build