linux-starfive-dev.bbappend 2.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. FORK:starfive-dubhe = "starfive-tech"
  2. BRANCH:starfive-dubhe = "starfive-6.1-dubhe"
  3. SRCREV:starfive-dubhe = "0328291313ba8ad2cd6ac94df9039f2f4a365b6f"
  4. FORK:starfive-visionfive2 = "starfive-tech"
  5. BRANCH:starfive-visionfive2 = "JH7110_VisionFive2_devel"
  6. SRCREV:starfive-visionfive2 = "d9eee31aaec51ade1641391836c1f07dd2151a4a"
  7. LINUX_VERSION ?= "6.1.20"
  8. LINUX_VERSION:starfive-dubhe = "6.1.20"
  9. LINUX_VERSION:starfive-visionfive2 = "5.15.0"
  10. LINUX_VERSION_EXTENSTION:append:starfive-dubhe = "-starlight"
  11. FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
  12. SRC_URI:starfive-dubhe = " \
  13. git://git@192.168.110.45/${FORK}/linux.git;protocol=ssh;branch=${BRANCH} \
  14. file://cpio.cfg \
  15. "
  16. SRC_URI:starfive-visionfive2 = " \
  17. git://github.com/${FORK}/linux.git;protocol=https;branch=${BRANCH} \
  18. file://vf2.cfg \
  19. "
  20. INITRAMFS_IMAGE_BUNDLE:starfive-dubhe = "${@oe.utils.conditional('ENABLE_INIT','1','1','',d)}"
  21. INITRAMFS_IMAGE:starfive-dubhe = "${@oe.utils.conditional('ENABLE_INIT','1','dubhe-image-initramfs','',d)}"
  22. INITRAMFS_IMAGE:starfive-visionfive2 = "core-image-minimal-initramfs"
  23. # Temporary remove the patch to update the kernel, will create new patches after that
  24. SRC_URI:append:starfive-dubhe = "${@oe.utils.conditional('ENABLE_EXT4','1','file://ext4.patch','',d)}"
  25. SRC_URI:append:starfive-dubhe = "${@oe.utils.conditional('ENABLE_UBI','1','file://ubi.patch','',d)}"
  26. KBUILD_DEFCONFIG:starfive-dubhe = "starfive_dubhe_defconfig"
  27. KBUILD_DEFCONFIG:starfive-visionfive2 = "starfive_visionfive2_defconfig"
  28. COMPATIBLE_MACHINE = "(starfive-dubhe|starfive-visionfive2)"
  29. FILES:${KERNEL_PACKAGE_NAME}-base += "/usr/*"
  30. DEPENDS:starfive-visionfive2 += " u-boot-tools-native u-boot-starfive"
  31. do_deploy:append:starfive-visionfive2 () {
  32. # Create FitImage
  33. cd ${DEPLOY_DIR_IMAGE}
  34. rm -rf ${DEPLOY_DIR_IMAGE}/tmp
  35. mkdir ${DEPLOY_DIR_IMAGE}/tmp
  36. cp -P ${DEPLOYDIR}/* ${DEPLOY_DIR_IMAGE}/tmp/
  37. mkimage -A riscv -O linux -T ramdisk -n "Initial Ram Disk" -d core-image-minimal-initramfs-starfive-visionfive2.cpio.gz initramfs.img
  38. mkimage -f ${DEPLOY_DIR_IMAGE}/visionfive2-fit-image.its ${DEPLOY_DIR_IMAGE}/starfiveu.fit
  39. }
  40. do_compile[nostamp] = "1"