openmp_16.0.5.bb 2.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. # Copyright (C) 2017 Khem Raj <raj.khem@gmail.com>
  2. # Released under the MIT license (see COPYING.MIT for the terms)
  3. DESCRIPTION = "LLVM based C/C++ compiler Runtime"
  4. HOMEPAGE = "https://openmp.llvm.org/"
  5. SECTION = "libs"
  6. require clang.inc
  7. require common-source.inc
  8. TOOLCHAIN = "clang"
  9. LIC_FILES_CHKSUM = "file://openmp/LICENSE.TXT;md5=d75288d1ce0450b28b8d58a284c09c79"
  10. inherit cmake pkgconfig perlnative python3native python3targetconfig
  11. DEPENDS += "elfutils libffi clang"
  12. EXTRA_OECMAKE += "-DCMAKE_BUILD_TYPE=RelWithDebInfo \
  13. -DLLVM_ENABLE_PER_TARGET_RUNTIME_DIR=OFF \
  14. -DOPENMP_LIBDIR_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
  15. -DOPENMP_STANDALONE_BUILD=ON \
  16. -DCLANG_TOOL=${STAGING_BINDIR_NATIVE}/clang \
  17. -DLINK_TOOL=${STAGING_BINDIR_NATIVE}/llvm-link \
  18. -DOPT_TOOL=${STAGING_BINDIR_NATIVE}/opt \
  19. -DOPENMP_LLVM_LIT_EXECUTABLE=${STAGING_BINDIR_NATIVE}/llvm-lit \
  20. -DEXTRACT_TOOL=${STAGING_BINDIR_NATIVE}/llvm-extract \
  21. -DPACKAGER_TOOL=${STAGING_BINDIR_NATIVE}/clang-offload-packager \
  22. -DCMAKE_POSITION_INDEPENDENT_CODE=ON \
  23. "
  24. OECMAKE_SOURCEPATH = "${S}/openmp"
  25. PACKAGECONFIG ?= "ompt-tools offloading-plugin"
  26. PACKAGECONFIG:remove:arm = "ompt-tools offloading-plugin"
  27. PACKAGECONFIG:remove:powerpc = "ompt-tools offloading-plugin"
  28. PACKAGECONFIG:append:mipsarcho32 = " no-atomics"
  29. PACKAGECONFIG[ompt-tools] = "-DOPENMP_ENABLE_OMPT_TOOLS=ON,-DOPENMP_ENABLE_OMPT_TOOLS=OFF,"
  30. PACKAGECONFIG[aliases] = "-DLIBOMP_INSTALL_ALIASES=ON,-DLIBOMP_INSTALL_ALIASES=OFF,"
  31. PACKAGECONFIG[offloading-plugin] = ",,elfutils libffi,libelf libffi"
  32. PACKAGECONFIG[no-atomics] = "-DLIBOMP_HAVE_BUILTIN_ATOMIC=OFF -DLIBOMP_LIBFLAGS='-latomic',,"
  33. PACKAGES += "${PN}-libomptarget ${PN}-gdb-plugin"
  34. FILES_SOLIBSDEV = ""
  35. FILES:${PN} += "${libdir}/lib*${SOLIBSDEV}"
  36. FILES:${PN}-libomptarget = "${libdir}/libomptarget-*.bc"
  37. FILES:${PN}-gdb-plugin = "${datadir}/gdb/python/ompd"
  38. RDEPENDS:${PN}-gdb-plugin += "python3-core"
  39. INSANE_SKIP:${PN} = "dev-so"
  40. # Currently the static libraries contain buildpaths
  41. INSANE_SKIP:${PN}-staticdev += "buildpaths"
  42. COMPATIBLE_HOST:mips64 = "null"
  43. COMPATIBLE_HOST:riscv32 = "null"
  44. COMPATIBLE_HOST:powerpc = "null"
  45. BBCLASSEXTEND = "native nativesdk"
  46. # This appears to be specific to the Intel distribution before 2022.1
  47. CVE_CHECK_IGNORE += "CVE-2022-26345"