nativesdk-clang-glue.bb 932 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright (C) 2014 Khem Raj <raj.khem@gmail.com>
  2. # Released under the MIT license (see COPYING.MIT for the terms)
  3. DESCRIPTION = "SDK Cross compiler wrappers for LLVM based C/C++ compiler"
  4. HOMEPAGE = "http://clang.llvm.org/"
  5. LICENSE = "Apache-2.0-with-LLVM-exception"
  6. LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0-with-LLVM-exception;md5=0bcd48c3bdfef0c9d9fd17726e4b7dab"
  7. SECTION = "devel"
  8. inherit nativesdk
  9. DEPENDS += "nativesdk-clang"
  10. do_install() {
  11. install -d ${D}${prefix_nativesdk}
  12. cd ${D}${prefix_nativesdk}
  13. ln -s ..${libdir} .
  14. ln -s ..${includedir} .
  15. cd ..
  16. ln -s .${base_libdir} .
  17. }
  18. sysroot_stage_all () {
  19. sysroot_stage_dir ${D} ${SYSROOT_DESTDIR}
  20. }
  21. FILES:${PN} += "${prefix_nativesdk} ${base_libdir_nativesdk}"
  22. FILES:${PN}-dbg = ""
  23. deltask do_configure
  24. deltask do_compile
  25. deltask do_patch
  26. deltask do_fetch
  27. deltask do_unpack
  28. deltask do_create_spdx
  29. deltask do_create_runtime_spdx