llvm-project-source.bbappend 3.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. FILESEXTRAPATHS:prepend := "${THISDIR}/clang:"
  2. SRCREV = "35bd94a4b791787e7f3938e10ce80f409831dd7e"
  3. BRANCH = "release/16.x"
  4. SRC_URI = "\
  5. ${BASEURI} \
  6. file://llvm-config \
  7. file://libunwind.pc.in \
  8. file://0001-neon2rvv-support-type-convert-between-fixed-vector-a.patch \
  9. file://0002-neon2rvv-Model-vxrm-in-LLVM-intrinsics-and-add-optim.patch \
  10. file://0003-RISCV-Add-prefetch-instructions.patch \
  11. file://0004-RISCV-Add-customer-cache-instructions.patch \
  12. file://0005-RISCV-Add-multilib-v-b-support-for-baremetal-toolcha.patch \
  13. file://0006-RISCV-Change-baremetal-multilib-directory-name-to-al.patch \
  14. file://0007-Driver-Set-clang-default-dwarf-version-to-4.patch \
  15. file://0008-RISCV-Support-b-letter-in-march-string.patch \
  16. file://0009-RISCV-Align-default-march-with-dubhe-gcc-toolchain.patch \
  17. file://0001-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch \
  18. file://0002-compiler-rt-support-a-new-embedded-linux-target.patch \
  19. file://0003-compiler-rt-Simplify-cross-compilation.-Don-t-use-na.patch \
  20. file://0004-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch \
  21. file://0005-llvm-allow-env-override-of-exe-and-libdir-path.patch \
  22. file://0006-clang-driver-Check-sysroot-for-ldso-path.patch \
  23. file://0007-clang-Driver-tools.cpp-Add-lssp_nonshared-on-musl.patch \
  24. file://0008-clang-Prepend-trailing-to-sysroot.patch \
  25. file://0009-clang-Look-inside-the-target-sysroot-for-compiler-ru.patch \
  26. file://0010-clang-Define-releative-gcc-installation-dir.patch \
  27. file://0011-clang-Add-lpthread-and-ldl-along-with-lunwind-for-st.patch \
  28. file://0012-Pass-PYTHON_EXECUTABLE-when-cross-compiling-for-nati.patch \
  29. file://0013-Check-for-atomic-double-intrinsics.patch \
  30. file://0014-libcxx-Add-compiler-runtime-library-to-link-step-for.patch \
  31. file://0015-clang-llvm-cmake-Fix-configure-for-packages-using-fi.patch \
  32. file://0016-clang-Fix-resource-dir-location-for-cross-toolchains.patch \
  33. file://0017-clang-driver-Add-dyld-prefix-when-checking-sysroot-f.patch \
  34. file://0018-clang-Use-python3-in-python-scripts.patch \
  35. file://0019-For-x86_64-set-Yocto-based-GCC-install-search-path.patch \
  36. file://0020-llvm-Do-not-use-find_library-for-ncurses.patch \
  37. file://0021-llvm-Insert-anchor-for-adding-OE-distro-vendor-names.patch \
  38. file://0022-compiler-rt-Do-not-use-backtrace-APIs-on-non-glibc-l.patch \
  39. file://0023-clang-Fix-x86-triple-for-non-debian-multiarch-linux-.patch \
  40. file://0024-libunwind-Added-unw_backtrace-method.patch \
  41. file://0025-clang-Do-not-use-install-relative-libc-headers.patch \
  42. file://0026-clang-Fix-how-driver-finds-GCC-installation-path-on-.patch \
  43. file://0027-Fix-lib-paths-for-OpenEmbedded-Host.patch \
  44. file://0028-Correct-library-search-path-for-OpenEmbedded-Host.patch \
  45. file://0029-lldb-Link-with-libatomic-on-x86.patch \
  46. file://0030-clang-exclude-openembedded-distributions-from-settin.patch \
  47. file://0031-compiler-rt-Enable-__int128-for-ppc32.patch \
  48. file://0032-llvm-Do-not-use-cmake-infra-to-detect-libzstd.patch \
  49. file://0033-build-Enable-64bit-off_t-on-32bit-glibc-systems.patch \
  50. file://0034-compiler-rt-Undef-_TIME_BITS-along-with-_FILE_OFFSET.patch \
  51. file://0035-compiler-rt-Fix-stat-struct-s-size-for-O32-ABI.patch \
  52. file://0036-compiler-rt-Undef-_TIME_BITS-along-with-_FILE_OFFSET.patch \
  53. file://0037-clang-Call-printName-to-get-name-of-Decl.patch \
  54. "