Browse Source

dubhe: linux-starfive-dev: Remove additional device tree for different bootargs
The bootargs can be customized in the U-Boot console.
Hence, bootargs no longer needed to be set in device tree.

Signed-off-by: weiheng.cheng <weiheng.cheng@starfivetech.com>

weiheng.cheng 6 months ago
parent
commit
f81226e0f5

+ 0 - 9
recipes-kernel/linux/files/add-dubhe-additional-dtb.patch

@@ -1,9 +0,0 @@
-diff --git a/arch/riscv/boot/dts/starfive/Makefile b/arch/riscv/boot/dts/starfive/Makefile
-index afd54ff97bd3..19cec25ad47b 100644
---- a/arch/riscv/boot/dts/starfive/Makefile
-+++ b/arch/riscv/boot/dts/starfive/Makefile
-@@ -1,3 +1,4 @@
- # SPDX-License-Identifier: GPL-2.0
- dtb-$(CONFIG_SOC_STARFIVE) += jh7100-beaglev-starlight-a1.dtb jh7100-beaglev-starlight.dtb jh7100-starfive-visionfive-v1.dtb
- dtb-$(CONFIG_SOC_STARFIVE_DUBHE) += dubhe80_fpga.dtb dubhe90_fpga.dtb dubhe90_fpga_dual.dtb
-+dtb-$(CONFIG_SOC_STARFIVE_DUBHE) += dubhe90_fpga_ext4.dtb dubhe90_fpga_ubi.dtb dubhe90_fpga_nfs.dtb dubhe80_fpga_ext4.dtb dubhe80_fpga_ubi.dtb dubhe80_fpga_nfs.dtb

+ 3 - 31
recipes-kernel/linux/linux-starfive-dev_6.1.20.bb

@@ -27,10 +27,11 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
 SRC_URI:starfive-dubhe = " \
         git://git@192.168.110.45/${FORK}/linux.git;protocol=ssh;branch=${BRANCH} \
         file://cpio.cfg \
-	file://add-dubhe-additional-dtb.patch \
         "
-SRC_URI:starfive-jh8100 = "git://git@192.168.110.45/${FORK}/linux.git;protocol=ssh;branch=${BRANCH}"
 
+SRC_URI:starfive-jh8100 = "\
+	git://git@192.168.110.45/${FORK}/linux.git;protocol=ssh;branch=${BRANCH} \
+	"
 
 INITRAMFS_IMAGE_BUNDLE:starfive-dubhe = "1"
 INITRAMFS_IMAGE:starfive-dubhe = "dubhe-image-initramfs"
@@ -41,32 +42,3 @@ KBUILD_DEFCONFIG:starfive-jh8100 = "jh8100_defconfig"
 COMPATIBLE_MACHINE = "(starfive-dubhe|starfive-jh8100)"
 
 FILES:${KERNEL_PACKAGE_NAME}-base += "/usr/*"
-
-BOOTARGS_EXT4 = "console=ttySIF0,115200 earlycon=sbi root=/dev/mmcblk0p2 rw rootfstype=ext4 rootwait ip=:::255.255.255.0::eth0:dhcp"
-BOOTARGS_UBI = "console=ttySIF0,115200 earlycon=sbi ip=:::255.255.255.0::eth0:dhcp root=ubi0:starfive-dubhe-rootfs ubi.mtd=1 rw rootfstype=ubifs rootwait"
-BOOTARGS_NFS = "console=ttySIF0,115200 earlycon=sbi root=/dev/nfs rw nfsroot=192.168.1.1:/filepath,rw,tcp,vers=3,rsize=1048576,wsize=1048576 ip=:::255.255.255.0::eth0:dhcp rootfstype=ext4 rootwait"
-
-do_configure:append:starfive-dubhe() {
-	cp ${S}/arch/riscv/boot/dts/starfive/dubhe80_fpga.dts ${S}/arch/riscv/boot/dts/starfive/dubhe80_fpga_ext4.dts
-        cp ${S}/arch/riscv/boot/dts/starfive/dubhe80_fpga.dts ${S}/arch/riscv/boot/dts/starfive/dubhe80_fpga_ubi.dts
-        cp ${S}/arch/riscv/boot/dts/starfive/dubhe80_fpga.dts ${S}/arch/riscv/boot/dts/starfive/dubhe80_fpga_nfs.dts
-
-	cp ${S}/arch/riscv/boot/dts/starfive/dubhe90_fpga.dts ${S}/arch/riscv/boot/dts/starfive/dubhe90_fpga_ext4.dts
-	cp ${S}/arch/riscv/boot/dts/starfive/dubhe90_fpga.dts ${S}/arch/riscv/boot/dts/starfive/dubhe90_fpga_ubi.dts
-	cp ${S}/arch/riscv/boot/dts/starfive/dubhe90_fpga.dts ${S}/arch/riscv/boot/dts/starfive/dubhe90_fpga_nfs.dts
-
-	for dts_file in ${S}/arch/riscv/boot/dts/starfive/dubhe*0_fpga_*.dts; do
-		if [ "$dts_file" = "${S}/arch/riscv/boot/dts/starfive/dubhe90_fpga_dual.dts" ]; then
-			continue
-		fi
-		echo "/ {" >> "$dts_file"
-		echo "    chosen {" >> "$dts_file"
-		echo "        bootargs" >> "$dts_file"
-		echo "    };" >> "$dts_file"
-		echo "};" >> "$dts_file"
-	done
-
-	sed -i "s+bootargs+bootargs = \"${BOOTARGS_EXT4}\";+g" ${S}/arch/riscv/boot/dts/starfive/dubhe*0_fpga_ext4.dts
-	sed -i "s+bootargs+bootargs = \"${BOOTARGS_UBI}\";+g" ${S}/arch/riscv/boot/dts/starfive/dubhe*0_fpga_ubi.dts
-	sed -i "s+bootargs+bootargs = \"${BOOTARGS_NFS}\";+g" ${S}/arch/riscv/boot/dts/starfive/dubhe*0_fpga_nfs.dts
-}