Browse Source

meta-starfive: Yocto Kirkstone update

Added configurations for Kirkstone update and replace function class syntax as according to Kirkstone release.

Signed-off-by: yang.lee <yang.lee@starfivetech.com>
yang.lee 1 year ago
parent
commit
f0edf61be9

+ 29 - 0
conf/auto.conf

@@ -0,0 +1,29 @@
+MACHINE ?= "starfive-dubhe"
+#IMAGE_FEATURES += "tools-debug"
+#IMAGE_FEATURES += "tools-tweaks"
+#IMAGE_FEATURES += "dbg-pkgs"
+# rootfs for debugging
+#IMAGE_GEN_DEBUGFS = "1"
+#IMAGE_FSTYPES_DEBUGFS = "tar.gz"
+#EXTRA_IMAGE_FEATURES:append = " ssh-server-dropbear"
+EXTRA_IMAGE_FEATURES:append = " package-management"
+PACKAGECONFIG:append:pn-qemu-native = " sdl"
+PACKAGECONFIG:append:pn-nativesdk-qemu = " sdl"
+USER_CLASSES ?= "buildstats buildhistory buildstats-summary"
+
+require conf/distro/include/no-static-libs.inc
+require conf/distro/include/yocto-uninative.inc
+require conf/distro/include/security_flags.inc
+
+INHERIT += "uninative"
+
+DISTRO_FEATURES:append = " largefile opengl ptest multiarch wayland pam  systemd "
+DISTRO_FEATURES_BACKFILL_CONSIDERED += "sysvinit"
+VIRTUAL-RUNTIME_init_manager = "systemd"
+##VIRTUAL-RUNTIME_initscripts = ""
+##VIRTUAL-RUNTIME_syslog = ""
+HOSTTOOLS_NONFATAL:append = " ssh"
+
+DISTRO_NAME = "StarFive Linux SDK"
+#DISTRO_VERSION = ""
+#DISTRO_CODENAME = ""

+ 1 - 1
conf/layer.conf

@@ -8,4 +8,4 @@ BBFILE_PATTERN_meta-starfive = "^${LAYERDIR}/"
 BBFILE_PRIORITY_meta-starfive = "7"
 LAYERVERSION_meta-starfive = "1"
 
-LAYERSERIES_COMPAT_meta-starfive = "honister"
+LAYERSERIES_COMPAT_meta-starfive = "kirkstone"

+ 6 - 0
conf/machine/starfive-dubhe.conf

@@ -43,6 +43,12 @@ RISCV_SBI_PAYLOAD = "Image-initramfs-starfive-dubhe.bin"
 QEMU_EXTRAOPTIONS:riscv64 = " -cpu rv64,x-b=true,x-v=true"
 
 GLIBCVERSION = "2.35"
+
+BINUVERSION = "2.37"
+
+QEMUVERSION = "6.0.0"
+
+PREFERRED_VERSION_opensbi = "0.9"
 #
 ###IMAGE_FSTYPES += "wic.gz wic.bmap ext4 cpio"
 

+ 3 - 3
recipes-core/glibc/glibc_2.35.bb

@@ -1,20 +1,20 @@
 require glibc.inc
 require glibc-version.inc
 
-CVE_CHECK_WHITELIST += "CVE-2020-10029 CVE-2021-27645"
+CVE_CHECK_IGNORE += "CVE-2020-10029 CVE-2021-27645"
 
 # glibc https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-1010022
 # glibc https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-1010023
 # glibc https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-1010024
 # Upstream glibc maintainers dispute there is any issue and have no plans to address it further.
 # "this is being treated as a non-security bug and no real threat."
-CVE_CHECK_WHITELIST += "CVE-2019-1010022 CVE-2019-1010023 CVE-2019-1010024"
+CVE_CHECK_IGNORE += "CVE-2019-1010022 CVE-2019-1010023 CVE-2019-1010024"
 
 # glibc https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-1010025
 # Allows for ASLR bypass so can bypass some hardening, not an exploit in itself, may allow
 # easier access for another. "ASLR bypass itself is not a vulnerability."
 # Potential patch at https://sourceware.org/bugzilla/show_bug.cgi?id=22853
-CVE_CHECK_WHITELIST += "CVE-2019-1010025"
+CVE_CHECK_IGNORE += "CVE-2019-1010025"
 
 DEPENDS += "gperf-native bison-native make-native"
 

+ 1 - 1
recipes-devtools/gcc/gcc-target.inc

@@ -257,4 +257,4 @@ do_install:append () {
 # and builds track file dependencies (e.g. perl and its makedepends code).
 # For determinism we don't install this ever and rely on the copy from gcc-cross.
 # [YOCTO #7287]
-SYSROOT_DIRS_BLACKLIST += "${libdir}/gcc"
+SYSROOT_DIRS_IGNORE += "${libdir}/gcc"

+ 1 - 1
recipes-devtools/gdb/gdb-cross-canadian.inc

@@ -18,7 +18,7 @@ PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,native
                          "
 PACKAGECONFIG[readline] = "--with-system-readline,--without-system-readline,nativesdk-readline"
 
-SSTATE_DUPWHITELIST += "${STAGING_DATADIR}/gdb"
+SSTATE_ALLOW_OVERLAP_FILES += "${STAGING_DATADIR}/gdb"
 
 do_configure:prepend() {
 cat > ${WORKDIR}/python << EOF