Browse Source

dubhe: linux-starfive-dev: Update source and patch

Update source uri to use same variable and apply conditional patch files.

Signed-off-by: yang.lee <yang.lee@starfivetech.com>
yang.lee 1 year ago
parent
commit
d229374478

+ 1 - 1
recipes-kernel/linux/files/nfs.patch

@@ -7,7 +7,7 @@ index 89098aab24d9..0d43a18bd446 100644
  
  	chosen {
 -		bootargs = "console=ttySIF0,115200 earlycon=sbi root=/dev/nfs nfsroot=192.168.153.221:/home/nfsroot,rw,tcp,vers=3 ip=192.168.152.100:192.168.153.221:192.168.152.1:255.255.255.0::eth0:off";
-+		bootargs = "console=ttySIF0,115200 earlycon=sbi root=/dev/nfs rw nfsroot=192.168.153.221:/home/weiheng.cheng/nfsroot,rw,tcp,vers=3  ip=192.168.152.100:192.168.153.221:192.168.152.1:255.255.255.0::eth0:off rootfstype=ext4 rootwait";
++		bootargs = "console=ttySIF0,115200 earlycon=sbi root=/dev/nfs rw nfsroot=192.168.1.1:/filepath,rw,tcp,vers=3  ip=192.168.1.1:192.168.1.1:192.168.1.1:255.255.255.0::eth0:off rootfstype=ext4 rootwait";
  	};
  
  	cpus {

+ 2 - 8
recipes-kernel/linux/linux-starfive-dev.bbappend

@@ -7,20 +7,14 @@ LINUX_VERSION_EXTENSION:append = "-starlight"
 
 FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
 
-SRC_TMP_B = "git://git@192.168.110.45/starfive-tech/linux.git;protocol=ssh;branch=${BRANCH} \
-	   file://defconfig \
-           file://nfs.patch \
-	   "
-
-SRC_TMP_A = "git://git@192.168.110.45/starfive-tech/linux.git;protocol=ssh;branch=${BRANCH} \
+SRC_URI = "git://git@192.168.110.45/starfive-tech/linux.git;protocol=ssh;branch=${BRANCH} \
            file://defconfig \
-	   file://initramfs.patch \
            "
 
 INITRAMFS_IMAGE_BUNDLE = "${@oe.utils.conditional('ENABLE_NFS','1','','1',d)}"
 INITRAMFS_IMAGE = "${@oe.utils.conditional('ENABLE_NFS','1','','dubhe-image-initramfs',d)}"
 
-SRC_URI = "${@oe.utils.conditional('ENABLE_NFS','1','${SRC_TMP_B}','${SRC_TMP_A}',d)}"
+SRC_URI:append = "${@oe.utils.conditional('ENABLE_NFS','1','file://nfs.patch','file://initramfs.patch',d)}"
 
 #KBUILD_DEFCONFIG_starfive = "starfive_dubhe_defconfig"