Browse Source

dubhe: Update Dubhe initramfs image recipe

Changed PACKAGE_INSTALL and EXTRA_IMAGEDEPENDS from = to ?= for default.
This will enable user to add extra packages or dependencies from
machine.conf or local.conf files (was unable to add from config files
previously)

Signed-off-by: Jun Yuan Tan <junyuan.tan@starfivetech.com>
Jun Yuan Tan 2 years ago
parent
commit
cc464b2c8e

+ 2 - 1
conf/machine/starfive-dubhe.conf

@@ -47,7 +47,7 @@ INITRAMFS_MAXSIZE = "524288"
 PREFERRED_PROVIDER_virtual/kernel ?= "linux-starfive-dev"
 #PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-starfive"
 #EXTRA_IMAGEDEPENDS += "u-boot"
-EXTRA_IMAGEDEPENDS += "opensbi"
+#EXTRA_IMAGEDEPENDS += "opensbi"
 RISCV_SBI_PLAT = "generic"
 RISCV_SBI_PAYLOAD = "Image-initramfs-starfive-dubhe.bin"
 
@@ -55,6 +55,7 @@ PREFERRED_VERSION_qemu = "6.1.0-rc1"
 PREFERRED_VERSION_qemu-native = "6.1.0-rc1"
 PREFERRED_VERSION_nativesdk-qemu = "6.1.0-rc1"
 QEMU_EXTRAOPTIONS_riscv64 = " -cpu rv64,x-b=true"
+
 #
 ###IMAGE_FSTYPES += "wic.gz wic.bmap ext4 cpio"
 

+ 2 - 2
recipes-images/images/dubhe-image-initramfs.bb

@@ -6,7 +6,7 @@ first 'init' program more efficiently."
 INITRAMFS_SCRIPTS ?= "\
                       initramfs-boot packagegroup-core-boot \
                      "
-PACKAGE_INSTALL = "${INITRAMFS_SCRIPTS} ${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} helloworld coremark dhrystone"
+PACKAGE_INSTALL ?= "${INITRAMFS_SCRIPTS} ${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} helloworld coremark dhrystone"
 
 
 # Do not pollute the initrd image with rootfs features
@@ -24,7 +24,7 @@ inherit core-image
 
 IMAGE_ROOTFS_SIZE = "8192"
 IMAGE_ROOTFS_EXTRA_SPACE = "0"
-EXTRA_IMAGEDEPENDS = ""
+EXTRA_IMAGEDEPENDS ?= ""
 
 # Use the same restriction as initramfs-module-install
 COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*|riscv64.*|rv64.*)-(linux.*|freebsd.*)'