Browse Source

dubhe: kvmtool: Update SRCREV
Newer version of kvmtool.

Signed-off-by: weiheng.cheng <weiheng.cheng@starfivetech.com>

weiheng.cheng 10 months ago
parent
commit
cb2e9895e3

+ 1 - 0
recipes-core/initrdscripts/files/init-boot.sh

@@ -11,4 +11,5 @@ mknod -m 666 /dev/mem c 1 1
 
 mknod /dev/ttyS0 c 4 64
 mknod /dev/ttySIF0 c 249 0
+mknod /dev/kvm c 10 232
 setsid cttyhack /bin/sh

+ 13 - 13
recipes-extended/kvmtool/files/external-crosscompiler.patch

@@ -13,11 +13,11 @@ be linked against the cross-compiled libfdt library.
  Makefile | 8 +-------
  1 file changed, 1 insertion(+), 7 deletions(-)
 
-diff --git a/Makefile b/Makefile
-index e9121dc..c05b2c0 100644
---- a/Makefile
-+++ b/Makefile
-@@ -19,12 +19,6 @@ include config/utilities.mak
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile
++++ git/Makefile
+@@ -19,12 +19,6 @@
  include config/feature-tests.mak
  -include $(OUTPUT)KVMTOOLS-VERSION-FILE
  
@@ -30,12 +30,12 @@ index e9121dc..c05b2c0 100644
  FIND	:= find
  CSCOPE	:= cscope
  TAGS	:= ctags
-@@ -343,7 +337,7 @@ $(warning No static libc found. Skipping guest init)
- endif
- 
- ifeq (y,$(ARCH_WANT_LIBFDT))
--	ifneq ($(call try-build,$(SOURCE_LIBFDT),$(CFLAGS),-lfdt),y)
-+	ifneq ($(call try-build,$(SOURCE_LIBFDT),$(CPPFLAGS) $(CFLAGS),-lfdt),y)
-           $(error No libfdt found. Please install libfdt-dev package)
- 	else
+@@ -367,7 +361,7 @@
+ 		CFLAGS_DYNOPT	+= -DCONFIG_HAS_LIBFDT
+ 		CFLAGS_STATOPT	+= -DCONFIG_HAS_LIBFDT
+ 		CFLAGS		+= -I $(LIBFDT_DIR)
+-	else ifeq ($(call try-build,$(SOURCE_LIBFDT),$(CFLAGS),-lfdt),y)
++	else ifeq ($(call try-build,$(SOURCE_LIBFDT),$(CPPFLAGS) $(CFLAGS),-lfdt),y)
+ 		LIBFDT_STATIC	:=
  		CFLAGS_DYNOPT	+= -DCONFIG_HAS_LIBFDT
+ 		CFLAGS_STATOPT	+= -DCONFIG_HAS_LIBFDT

+ 9 - 8
recipes-extended/kvmtool/kvmtool.bb

@@ -9,14 +9,15 @@ do_configure[depends] += "virtual/kernel:do_shared_workdir"
 
 inherit kernel-arch
 
-SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/will/kvmtool.git;branch=master \
-           file://external-crosscompiler.patch \
-           file://0001-kvmtool-9p-fixed-compilation-error.patch \
-           file://0002-kvmtool-add-EXTRA_CFLAGS-variable.patch \
-           file://0003-kvmtool-Werror-disabled.patch \
-           "
-
-SRCREV = "faae833a746f1c59f64fb05e9c08e62b5b0002eb"
+SRC_URI = " \
+	git://git.kernel.org/pub/scm/linux/kernel/git/will/kvmtool.git;branch=master \
+	file://external-crosscompiler.patch \
+	file://0001-kvmtool-9p-fixed-compilation-error.patch \
+	file://0002-kvmtool-add-EXTRA_CFLAGS-variable.patch \
+	file://0003-kvmtool-Werror-disabled.patch \
+	"
+
+SRCREV = "336751fb10ef24e65cd2f25c450da1d52ff5b33c"
 PV = "5.10.0+git${SRCPV}"
 
 S = "${WORKDIR}/git"