Browse Source

dubhe: setup.sh: Update image choices
Change qspi-image description and hide obsolete images.

Signed-off-by: weiheng.cheng <weiheng.cheng@starfivetech.com>

weiheng.cheng 6 months ago
parent
commit
c48f6580c8
1 changed files with 53 additions and 54 deletions
  1. 53 54
      setup.sh

+ 53 - 54
setup.sh

@@ -158,32 +158,34 @@ echo "";
 echo "This build script can build three types of image.";
 echo "";
 echo "1) QSPI-Image";
-echo "   - Initramfs has been bundled into qspi-image.";
+echo "   - QSPI image that boots image via TFTP";
 echo "   - Generated output : ";
-echo "     QSPI-Image.bin";
-echo "2) Dubhe-Image-Minimal";
-echo "   - Minimal image with ext4 support.";
-echo "   - Generated output : ";
-echo "     QSPI-EXT4-Image.bin";
-echo "     SD-Image.img";
-echo "3) QSPI-Ubifs-Image";
-echo "   - Minimal image with ubifs support.";
-echo "   - Generated output : ";
-echo -e "     QSPI-Ubifs-Image.bin";
-echo "4) QSPI-NFS-Image";
-echo "   - NFS config has been enabled.";
-echo "   - Generated output : ";
-echo -e "     QSPI-NFS-Image.bin${NC}";
+echo "     starfive-dubhe-qspi-tftpboot.bin";
+echo "     Image-initramfs-starfive-dubhe.bin";
+echo "     dubhe80_fpga.dtb"
+echo -e "     dubhe90_fpga.dtb${NC}";
+#echo "2) Dubhe-Image-Minimal";
+#echo "   - Minimal image with ext4 support.";
+#echo "   - Generated output : ";
+#echo "     QSPI-EXT4-Image.bin";
+#echo "     SD-Image.img";
+#echo "3) QSPI-Ubifs-Image";
+#echo "   - Minimal image with ubifs support.";
+#echo "   - Generated output : ";
+#echo -e "     QSPI-Ubifs-Image.bin";
+#echo "4) QSPI-NFS-Image";
+#echo "   - NFS config has been enabled.";
+#echo "   - Generated output : ";
+#echo -e "     QSPI-NFS-Image.bin${NC}";
 echo "";
 
 PS3="Select your action : "
-options=("Build qspi-image" "Build dubhe-image-minimal" "Build qspi-ubifs-image" "Build qspi-nfs-image" "Quit")
+options=("Build qspi-image" "Quit")
 
 select opt in "${options[@]}"
 do
     case $opt in
         "Build qspi-image")
-#            cd ../build || { echo "Run setup.sh before building images."; cd meta-starfive; break; };
 	    updatecfg ENABLE_INIT;
             cur_ter=$(tty);
             output=$(MACHINE=starfive-dubhe bitbake qspi-image | tee $cur_ter);
@@ -192,43 +194,40 @@ do
                 runprog dubhe-image-initramfs;
             else echo -e "\U000274C ${RED}Build Failed${NC}"
             fi;;
-	"Build dubhe-image-minimal")
-#           cd ../build || { echo "Run setup.sh before building images."; cd meta-starfive; break; };
-	    updatecfg ENABLE_EXT4
-            cur_ter=$(tty);
-            output_min=$(MACHINE=starfive-dubhe bitbake dubhe-image-minimal | tee $cur_ter);
-            if [[ $output_min != *"ERROR"* ]]; then
-                echo -e "\U0002705 ${GREEN}Build Complete${NC}"
-                runprog console-image-minimal;
-            else echo -e "\U000274C ${RED}Build Failed${NC}"
-            fi;;
-	"Build qspi-ubifs-image")
-#            cd ../build || { echo "Run setup.sh before building images."; cd meta-starfive; break; };
-	    updatecfg ENABLE_UBI
-            cur_ter=$(tty);
-            output=$(MACHINE=starfive-dubhe bitbake qspi-ubifs-image | tee $cur_ter);
-            if [[ $output != *"ERROR"* ]]; then
-                echo -e "\U0002705 ${GREEN}Build Complete${NC}"
-            else echo -e "\U000274C ${RED}Build Failed${NC}"
-            fi;;
-        "Build qspi-nfs-image")
-#           cd ../build || { echo "Run setup.sh before building images."; cd meta-starfive; break; };
-	    sed -n 47p ../meta-starfive/recipes-kernel/linux/linux-starfive-dev_6.1.20.bb;
-	    read -p "Kindly confirm boot argument such as nfs path and ip address before build (/meta-starfive/recipes-kernel/linux/files/nfs.patch). Proceed to build?[Y/n]:" RES;
-	    case $RES in
-		[Yy])
-			updatecfg ENABLE_NFS
-			cur_ter=$(tty);
-			output_min=$(MACHINE=starfive-dubhe bitbake qspi-nfs-image | tee $cur_ter);
-			if [[ $output_min != *"ERROR"* ]]; then
-				echo -e "\U0002705 ${GREEN}Build Complete${NC}"
-			else echo -e "\U000274C ${RED}Build Failed${NC}"
-			fi;;
-		 [Nn])
-			return;;
-		 *)
-			echo "Invalid option $RES , [Y/n] only.";
-			esac;;
+#	"Build dubhe-image-minimal")
+#	    updatecfg ENABLE_EXT4
+#            cur_ter=$(tty);
+#            output_min=$(MACHINE=starfive-dubhe bitbake dubhe-image-minimal | tee $cur_ter);
+#            if [[ $output_min != *"ERROR"* ]]; then
+#                echo -e "\U0002705 ${GREEN}Build Complete${NC}"
+#                runprog console-image-minimal;
+#            else echo -e "\U000274C ${RED}Build Failed${NC}"
+#            fi;;
+#	"Build qs#pi-ubifs-image")
+#	    updatecfg ENABLE_UBI
+#            cur_ter=$(tty);
+#            output=$(MACHINE=starfive-dubhe bitbake qspi-ubifs-image | tee $cur_ter);
+#            if [[ $output != *"ERROR"* ]]; then
+#                echo -e "\U0002705 ${GREEN}Build Complete${NC}"
+#            else echo -e "\U000274C ${RED}Build Failed${NC}"
+#            fi;;
+#        "Build qspi-nfs-image")
+#	    sed -n 47p ../meta-starfive/recipes-kernel/linux/linux-starfive-dev_6.1.20.bb;
+#	    read -p "Kindly confirm boot argument such as nfs path and ip address before build (/meta-starfive/recipes-kernel/linux/linux-starfive-dev_6.1.20). Proceed to build?[Y/n]:" RES;
+#	    case $RES in
+#		[Yy])
+#			updatecfg ENABLE_NFS
+#			cur_ter=$(tty);
+#			output_min=$(MACHINE=starfive-dubhe bitbake qspi-nfs-image | tee $cur_ter);
+#			if [[ $output_min != *"ERROR"* ]]; then
+#				echo -e "\U0002705 ${GREEN}Build Complete${NC}"
+#			else echo -e "\U000274C ${RED}Build Failed${NC}"
+#			fi;;
+#		 [Nn])
+#			return;;
+#		 *)
+#			echo "Invalid option $RES , [Y/n] only.";
+#			esac;;
 	"Quit")
             break;;
         *)