浏览代码

jh8100: u-boot: Update u-boot recipe for jh8100 support

Added jh8100 u-boot source branch and dependency.

Signed-off-by: yang.lee <yang.lee@starfivetech.com>
yang.lee 9 月之前
父节点
当前提交
b409945606
共有 1 个文件被更改,包括 30 次插入7 次删除
  1. 30 7
      recipes-bsp/u-boot/u-boot-starfive.bb

+ 30 - 7
recipes-bsp/u-boot/u-boot-starfive.bb

@@ -3,13 +3,18 @@ require recipes-bsp/u-boot/u-boot.inc
 
 inherit uboot-extlinux-config
 
+LIC_FILES_CHKSUM:starfive-visionfive2 = "file://Licenses/README;md5=5a7450c57ffe5ae63fd732446b988025"
+LIC_FILES_CHKSUM:starfive-jh8100 = "file://Licenses/README;md5=2ca5f2c35c8cc335f0a19756634782f1"
+
 FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
 
-FORK = "starfive-tech"
-BRANCH = "JH7110_VisionFive2_devel"
-SRCREV = "b6e2b0e85c774a18ae668223a6e5f7d335895243"
+FORK:starfive-visionfive2 = "starfive-tech"
+BRANCH:starfive-visionfive2 = "JH7110_VisionFive2_devel"
+
+FORK:starfive-jh8100 = "starfive-tech"
+BRANCH:starfive-jh8100 = "jh8100_fpga_dev_v2023.01_bmc"
 
-SRC_URI = "git://github.com/${FORK}/u-boot.git;protocol=https;branch=${BRANCH} \
+SRC_URI:starfive-visionfive2 = "git://github.com/${FORK}/u-boot.git;protocol=ssh;branch=${BRANCH} \
            file://vf2_uEnv.txt \
 	   file://vf2_nvme_uEnv.txt \
 	   file://tftp-mmc-boot.txt \
@@ -17,7 +22,15 @@ SRC_URI = "git://github.com/${FORK}/u-boot.git;protocol=https;branch=${BRANCH} \
 	   file://uboot_disable_logo.patch \
           "
 
-DEPENDS:append = " u-boot-tools-native starfive-tool-native"
+SRC_URI:starfive-jh8100 = "git://git@192.168.110.45/${FORK}/u-boot.git;protocol=ssh;branch=${BRANCH} \
+	 file://tftp-mmc-boot.txt \
+	"
+
+SRCREV:starfive-visionfive2 = "b6e2b0e85c774a18ae668223a6e5f7d335895243"
+SRCREV:starfive-jh8100 = "163e8d28c905711d76cbd5d78dafbd6e24b3f21d"
+
+DEPENDS:append:starfive-visionfive2 = " u-boot-tools-native starfive-tool-native"
+DEPENDS:append:starfive-jh8100 = " u-boot-tools-native bmap-tools-native opensbi"
 
 # Overwrite this for your server
 TFTP_SERVER_IP ?= "127.0.0.1"
@@ -25,7 +38,12 @@ TFTP_SERVER_IP ?= "127.0.0.1"
 do_configure:prepend() {
     sed -i -e 's,@SERVERIP@,${TFTP_SERVER_IP},g' ${WORKDIR}/tftp-mmc-boot.txt
     mkimage -O linux -T script -C none -n "U-Boot boot script" \
-        -d ${WORKDIR}/tftp-mmc-boot.txt ${WORKDIR}/${UBOOT_ENV_BINARY}
+	-d ${WORKDIR}/tftp-mmc-boot.txt ${WORKDIR}/${UBOOT_ENV_BINARY}
+}
+
+do_configure:prepend:starfive-jh8100() {
+    cp ${DEPLOY_DIR_IMAGE}/fw_dynamic.bin ${WORKDIR}/build/fw_dynamic.bin
+    export OPENSBI=${WORKDIR}/build/fw_dynamic.bin
 }
 
 do_deploy:append:starfive-visionfive2() {
@@ -37,7 +55,12 @@ do_deploy:append:starfive-visionfive2() {
     ln -sf ${SPL_IMAGE}.normal.out ${DEPLOYDIR}/${SPL_SYMLINK}.normal.out
 }
 
+do_deploy:append:starfive-jh8100() {
+    install -m 644 ${WORKDIR}/build/u-boot.itb ${DEPLOYDIR}/u-boot.itb
+    rm ${WORKDIR}/build/fw_dynamic.bin
+}
+
 TOOLCHAIN = "gcc"
 
-COMPATIBLE_MACHINE = "(starfive-visionfive2)"
+COMPATIBLE_MACHINE = "(starfive-visionfive2|starfive-jh8100)"