Browse Source

dubhe: opensbi: Update and clean up OpenSBI recipe
Update SRCREV for dubhe and remove obsolete Dubhe code due to U-Boot integration.
Move starfive-jh8100 recipe contents from opensbi_%.bb to opensbi_1.2.bb
Rename opensbi_%.bbappend with opensbi_1.0.bbappend (starfive-visionfive2).

Signed-off-by: weiheng.cheng <weiheng.cheng@starfivetech.com>

weiheng.cheng 6 months ago
parent
commit
a6128e3a62

+ 0 - 25
recipes-bsp/opensbi/opensbi_%.bbappend

@@ -1,25 +0,0 @@
-SRCREV:starfive-visionfive2 = "c6a092cd80112529cb2e92e180767ff5341b22a3"
-SRC_URI:starfive-visionfive2 = "git://github.com/starfive-tech/opensbi.git;protocol=https \
-                                file://visionfive2-uboot-fit-image.its \
-                               "
-
-SRCREV:starfive-jh8100 = "06c3d05b7f5f1e0aa24141e4de487313b620cea9"
-SRC_URI:starfive-jh8100 = "git://git@192.168.110.45/starfive-tech/opensbi.git;protocol=ssh;branch=fpga-starfive-v1.2-jh8100"
-
-EXTRA_OEMAKE:starfive-visionfive2 += "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= FW_TEXT_START=0x40000000"
-EXTRA_OEMAKE:starfive-jh8100 += "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= FW_OPTIONS=0 FW_TEXT_START=0x40000000 PLATFORM_DEFCONFIG=starfive_defconfig"
-
-DEPENDS:starfive-visionfive2:append = " u-boot-tools-native dtc-native"
-
-do_deploy:append:starfive-visionfive2() {
-        install -m 0644 ${WORKDIR}/visionfive2-uboot-fit-image.its ${DEPLOYDIR}/visionfive2-uboot-fit-image.its
-        cd ${DEPLOYDIR}
-        mkimage -f visionfive2-uboot-fit-image.its -A riscv -O u-boot -T firmware visionfive2_fw_payload.img
-}
-
-do_deploy:append:starfive-dubhe(){
-	oe_runmake clean
-	oe_runmake PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= PLATFORM_DEFCONFIG=starfive_defconfig FW_PAYLOAD_PATH=${DEPLOY_DIR_IMAGE}/Image-initramfs-starfive-dubhe.bin
-	install -m 755 ${B}/build/platform/generic/firmware/fw_payload.bin ${DEPLOYDIR}/fw_payload_initramfs.bin
-	install -m 755 ${B}/build/platform/generic/firmware/fw_payload.elf ${DEPLOYDIR}/fw_payload_initramfs.elf
-}

+ 18 - 0
recipes-bsp/opensbi/opensbi_1.0.bbappend

@@ -0,0 +1,18 @@
+FORK:starfive-visionfive2 = "starfive-tech"
+BRANCH:starfive-visionfive2 = "master"
+SRCREV:starfive-visionfive2 = "c6a092cd80112529cb2e92e180767ff5341b22a3"
+
+SRC_URI:starfive-visionfive2 = "\
+	git://github.com/${FORK}/opensbi.git;protocol=https;branch=${BRANCH} \
+	file://visionfive2-uboot-fit-image.its \
+	"
+
+EXTRA_OEMAKE:starfive-visionfive2 += "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= FW_TEXT_START=0x40000000"
+
+DEPENDS:starfive-visionfive2 += "u-boot-tools-native dtc-native"
+
+do_deploy:append:starfive-visionfive2() {
+	install -m 0644 ${WORKDIR}/visionfive2-uboot-fit-image.its ${DEPLOYDIR}/visionfive2-uboot-fit-image.its
+	cd ${DEPLOYDIR}
+	mkimage -f visionfive2-uboot-fit-image.its -A riscv -O u-boot -T firmware visionfive2_fw_payload.img
+}

+ 17 - 8
recipes-bsp/opensbi/opensbi_1.2.bb

@@ -8,18 +8,27 @@ require opensbi-payloads.inc
 
 inherit autotools-brokensep deploy
 
-SRCREV:starfive-dubhe = "3b7a16171029ca0a185789ca7cba583a5bf31b19"
-SRC_URI:starfive-dubhe = "git://git@192.168.110.45/starfive-tech/opensbi.git;protocol=ssh;branch=starfive-v1.2-dubhe"
+FORK:starfive-dubhe = "starfive-tech"
+BRANCH:starfive-dubhe = "starfive-v1.2-dubhe"
+SRCREV:starfive-dubhe = "a10e0837f215fb4ed25f195f2c511a41deb9c324"
 
-SRC_URI:remove:nezha = " \
-    file://0001-lib-utils-fdt-Require-match-data-to-be-const.patch \
-    file://0002-lib-utils-timer-Add-a-separate-compatible-for-the-D1.patch \
-"
+FORK:starfive-jh8100 = "starfive-tech"
+BRANCH:starfive-jh8100 = "fpga-starfive-v1.2-jh8100"
+SRCREV:starfive-jh8100 = "06c3d05b7f5f1e0aa24141e4de487313b620cea9"
+
+SRC_URI = "\
+	git://git@192.168.110.45/${FORK}/opensbi.git;protocol=ssh;branch=${BRANCH} \
+	"
+
+SRC_URI:remove:nezha = "\
+	file://0001-lib-utils-fdt-Require-match-data-to-be-const.patch \
+	file://0002-lib-utils-timer-Add-a-separate-compatible-for-the-D1.patch \
+	"
 
 S = "${WORKDIR}/git"
 
-EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= "
-EXTRA_OEMAKE:starfive-dubhe += "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= PLATFORM_DEFCONFIG=starfive_defconfig "
+EXTRA_OEMAKE:starfive-dubhe = "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= FW_OPTIONS=0 FW_TEXT_START=0x80100000 PLATFORM_DEFCONFIG=starfive_defconfig"
+EXTRA_OEMAKE:starfive-jh8100 = "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= FW_OPTIONS=0 FW_TEXT_START=0x40000000 PLATFORM_DEFCONFIG=starfive_defconfig"
 
 # If RISCV_SBI_PAYLOAD is set then include it as a payload
 EXTRA_OEMAKE:append = " ${@riscv_get_extra_oemake_image(d)}"