Explorar o código

vdec-module: add WAVE511 / vdec kernel module for video decoding

Andreas Cord-Landwehr hai 1 ano
pai
achega
9e16a1925c

+ 21 - 0
recipes-kernel/modules/vdec-module.bb

@@ -0,0 +1,21 @@
+SUMMARY = "Kernel module for WAVE511 video decoder"
+DESCRIPTION = "WAVE511 is a 4K multi-format decoder IP from Chip&Media to support both HEVC/H.265 and AVC/H.264 video \
+formats which provide high-performance decode capability. WAVE511 was also called VPU Dec."
+
+LICENSE = "ChipsMedia_VisionFive2"
+LIC_FILES_CHKSUM = "file://../../../LICENSE.txt;md5=16bead7cc56b053f5da0061ce0637ad2"
+
+COMPATIBLE_MACHINE = "visionfive2"
+
+WAVE511_MODULE_SRC = "git/wave511/code/vdi/linux/driver"
+
+inherit module
+require recipes-bsp/common/visionfive2-firmware.inc
+
+SRC_URI += " \
+    file://Makefile;subdir=${WAVE511_MODULE_SRC} \
+"
+
+S = "${WORKDIR}/${WAVE511_MODULE_SRC}"
+
+RPROVIDES:${PN} += "kernel-module-vdec"

+ 17 - 0
recipes-kernel/modules/vdec-module/Makefile

@@ -0,0 +1,17 @@
+# SPDX-FileCopyrightText: 2023 Andreas Cord-Landwehr <cordlandwehr@kde.org>
+# SPDX-License-Identifier: MIT
+
+obj-m := vdec.o
+
+SRC := $(shell pwd)
+
+all:
+	$(MAKE) -C $(KERNEL_SRC) M=$(SRC)
+
+modules_install:
+	$(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install
+
+clean:
+	rm -f *.o *~ core .depend .*.cmd *.ko *.mod.c
+	rm -f Module.markers Module.symvers modules.order
+	rm -rf .tmp_versions Modules.symvers