浏览代码

jh8100: core-image-minimal: Update recipe

Added packages for jh8100 core-image-minimal.

Signed-off-by: yang.lee <yang.lee@starfivetech.com>
yang.lee 9 月之前
父节点
当前提交
950313bc04
共有 2 个文件被更改,包括 6 次插入2 次删除
  1. 4 2
      recipes-core/images/core-image-minimal.bbappend
  2. 2 0
      recipes-core/images/sd-image.inc

+ 4 - 2
recipes-core/images/core-image-minimal.bbappend

@@ -1,6 +1,8 @@
 require sd-image.inc
 
-DEPENDS += " opensbi starfive-tool-native u-boot-tools-native dtc-native"
+DEPENDS:starfive-visionfive2 += " opensbi starfive-tool-native"
+
+IMAGE_FEATURES += " allow-empty-password empty-root-password"
 
 IMAGE_INSTALL += " \
 	helloworld \
@@ -17,4 +19,4 @@ IMAGE_INSTALL += " \
 	e2fsprogs-resize2fs \
 	"
 
-EXTRA_IMAGEDEPENDS += " alsa-lib libgpiod i2c-tools"
+EXTRA_IMAGEDEPENDS:starfive-visionfive2 += " alsa-lib libgpiod i2c-tools"

+ 2 - 0
recipes-core/images/sd-image.inc

@@ -1,6 +1,8 @@
 # Generate SD Card image and eMMC image
 # - Using spl_tool to fix img header to boot from eMMC
 
+DEPENDS += " u-boot-tools-native dtc-native"
+
 do_vf2_sd (){
         cd ${IMGDEPLOYDIR}
         bmaptool copy ${PN}-${MACHINE}.wic.gz ${DEPLOY_DIR_IMAGE}/${MACHINE}-${PN}.img