Browse Source

dubhe: setup.sh: Update setup script
Remove obsolete image choices and ENABLE_<boot_mode> conditional argument.
Update the user menu to core-image-minimal.
Now only can build core-image-minimal using this setup script.

Signed-off-by: weiheng.cheng <weiheng.cheng@starfivetech.com>

weiheng.cheng 4 months ago
parent
commit
8bc5190056
1 changed files with 10 additions and 74 deletions
  1. 10 74
      setup.sh

+ 10 - 74
setup.sh

@@ -126,23 +126,6 @@ case $RES in
 esac
 }
 
-updatecfg(){
-cfg=("ENABLE_INIT" "ENABLE_EXT4" "ENABLE_UBI" "ENABLE_NFS")
-for cfgname in ${cfg[@]}; do
-    if [[ $1 == ${cfgname} ]]; then
-        if ! grep -q $1 ./conf/local.conf; then
-            echo $1="\"1"\" >> ./conf/local.conf;
-        else sed -i "s/$1=\"0\"/$1=\"1\"/g"  ./conf/local.conf;
-        fi;
-    else
-        if ! grep -q ${cfgname} ./conf/local.conf; then
-            echo ${cfgname}="\"0"\" >> ./conf/local.conf;
-        else sed -i "s/${cfgname}=\"1\"/${cfgname}=\"0\"/g"  ./conf/local.conf;
-        fi;
-    fi;
-done
-}
-
 dubhe(){
 # Menu script
 echo ""
@@ -156,77 +139,30 @@ echo -e "${YELLOW}Description : ";
 echo "";
 echo "This build script can build three types of image.";
 echo "";
-echo "1) QSPI-Image";
-echo "   - QSPI image that boots image via TFTP";
+echo "1) core-image-minimal";
+echo "   - QSPI boot firmware with that boots image via TFTP and NFS";
 echo "   - Generated output : ";
-echo "     starfive-dubhe-qspi-tftpboot.bin";
+echo "     starfive-dubhe-qspi-firmware.bin";
+echo "     Image";
 echo "     Image-initramfs-starfive-dubhe.bin";
-echo "     dubhe80_fpga.dtb"
-echo -e "     dubhe90_fpga.dtb${NC}";
-#echo "2) Dubhe-Image-Minimal";
-#echo "   - Minimal image with ext4 support.";
-#echo "   - Generated output : ";
-#echo "     QSPI-EXT4-Image.bin";
-#echo "     SD-Image.img";
-#echo "3) QSPI-Ubifs-Image";
-#echo "   - Minimal image with ubifs support.";
-#echo "   - Generated output : ";
-#echo -e "     QSPI-Ubifs-Image.bin";
-#echo "4) QSPI-NFS-Image";
-#echo "   - NFS config has been enabled.";
-#echo "   - Generated output : ";
-#echo -e "     QSPI-NFS-Image.bin${NC}";
+echo "     Image-nfs-starfive-dubhe.tar.gz";
+echo "     Image-sd-starfive-dubhe.img";
+echo -e "     dubhe_fpga.dtb${NC}";
 echo "";
 
 PS3="Select your action : "
-options=("Build qspi-image" "Quit")
+options=("Build core-image-minimal" "Quit")
 
 select opt in "${options[@]}"
 do
     case $opt in
-        "Build qspi-image")
-	    updatecfg ENABLE_INIT;
+        "Build core-image-minimal")
             cur_ter=$(tty);
-            output=$(MACHINE=starfive-dubhe bitbake qspi-image | tee $cur_ter);
+            output=$(MACHINE=starfive-dubhe bitbake core-image-minimal | tee $cur_ter);
             if [[ $output != *"ERROR"* ]]; then
                 echo -e "\U0002705 ${GREEN}Build Complete${NC}"
-                runprog dubhe-image-initramfs;
             else echo -e "\U000274C ${RED}Build Failed${NC}"
             fi;;
-#	"Build dubhe-image-minimal")
-#	    updatecfg ENABLE_EXT4
-#            cur_ter=$(tty);
-#            output_min=$(MACHINE=starfive-dubhe bitbake dubhe-image-minimal | tee $cur_ter);
-#            if [[ $output_min != *"ERROR"* ]]; then
-#                echo -e "\U0002705 ${GREEN}Build Complete${NC}"
-#                runprog console-image-minimal;
-#            else echo -e "\U000274C ${RED}Build Failed${NC}"
-#            fi;;
-#	"Build qs#pi-ubifs-image")
-#	    updatecfg ENABLE_UBI
-#            cur_ter=$(tty);
-#            output=$(MACHINE=starfive-dubhe bitbake qspi-ubifs-image | tee $cur_ter);
-#            if [[ $output != *"ERROR"* ]]; then
-#                echo -e "\U0002705 ${GREEN}Build Complete${NC}"
-#            else echo -e "\U000274C ${RED}Build Failed${NC}"
-#            fi;;
-#        "Build qspi-nfs-image")
-#	    sed -n 47p ../meta-starfive/recipes-kernel/linux/linux-starfive-dev_6.1.20.bb;
-#	    read -p "Kindly confirm boot argument such as nfs path and ip address before build (/meta-starfive/recipes-kernel/linux/linux-starfive-dev_6.1.20). Proceed to build?[Y/n]:" RES;
-#	    case $RES in
-#		[Yy])
-#			updatecfg ENABLE_NFS
-#			cur_ter=$(tty);
-#			output_min=$(MACHINE=starfive-dubhe bitbake qspi-nfs-image | tee $cur_ter);
-#			if [[ $output_min != *"ERROR"* ]]; then
-#				echo -e "\U0002705 ${GREEN}Build Complete${NC}"
-#			else echo -e "\U000274C ${RED}Build Failed${NC}"
-#			fi;;
-#		 [Nn])
-#			return;;
-#		 *)
-#			echo "Invalid option $RES , [Y/n] only.";
-#			esac;;
 	"Quit")
             break;;
         *)