Browse Source

dubhe: isl: Added Integer Set Library (ISL) recipe for GCC.

Signed-off-by: weiheng.cheng <weiheng.cheng@starfivetech.com>
weiheng.cheng 1 year ago
parent
commit
861212af08
2 changed files with 24 additions and 0 deletions
  1. 12 0
      recipes-devtools/isl/isl.inc
  2. 12 0
      recipes-devtools/isl/isl_0.24.bb

+ 12 - 0
recipes-devtools/isl/isl.inc

@@ -0,0 +1,12 @@
+SUMMARY = "Integer Set Library"
+
+DESCRIPTION = "ISL is a thread-safe C library for manipulating sets and relations of integer points bounded by affine constraints"
+
+HOMEPAGE = "https://libisl.sourceforge.io/"
+LICENSE = "MIT"
+SECTION = "libs"
+
+BBCLASSEXTEND = "native nativesdk"
+
+inherit autotools
+

+ 12 - 0
recipes-devtools/isl/isl_0.24.bb

@@ -0,0 +1,12 @@
+require isl.inc
+
+DEPENDS = "gmp"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0c7c9ea0d2ff040ba4a25afa0089624b"
+
+SRC_URI = "https://gcc.gnu.org/pub/gcc/infrastructure/isl-${PV}.tar.bz2"
+
+SRC_URI[sha256sum] = "fcf78dd9656c10eb8cf9fbd5f59a0b6b01386205fe1934b3b287a0a1898145c0"
+
+S = "${WORKDIR}/isl-${PV}"
+