Browse Source

dubhe: core-image-minimal: Add packagegroup to Dubhe image
Dubhe series will now use core-image-minimal for root file system.
Remove bmap-tools as it's meant for host, not target.
Only JH8100 has I3C support.

Signed-off-by: weiheng.cheng <weiheng.cheng@starfivetech.com>

weiheng.cheng 4 months ago
parent
commit
8610a87284
1 changed files with 10 additions and 2 deletions
  1. 10 2
      recipes-core/images/core-image-minimal.bbappend

+ 10 - 2
recipes-core/images/core-image-minimal.bbappend

@@ -6,11 +6,19 @@ IMAGE_FEATURES += " allow-empty-password empty-root-password"
 
 IMAGE_INSTALL += " \
 	packagegroup-starfive-essentials \
-	bmap-tools \
 	systemd-analyze \
 	e2fsprogs-resize2fs \
 	parted \
-	i3c-tools \
         "
 
+IMAGE_INSTALL:starfive-dubhe += "\
+	packagegroup-starfive-dubhe-essentials \
+	packagegroup-starfive-dubhe-ltp \
+	mtd-utils \
+	"
+
+IMAGE_INSTALL:starfive-jh8100 += "\
+	i3c-tools \
+	"
+
 TOOLCHAIN_TARGET_TASK += "packagegroup-starfive-toolchain"