Forráskód Böngészése

xorg-xserver: configure X11 for usage on visionfive2

Andreas Cord-Landwehr 1 éve
szülő
commit
7e81879aa2

+ 41 - 0
recipes-graphics/xorg-xserver/xserver-xf86-config/xorg.conf

@@ -0,0 +1,41 @@
+Section "Device"
+        Identifier      "Video Device"
+        Driver          "modesetting"
+        # Option                "Atomic"                "true"
+        Option          "NoCursor"              "true"
+EndSection
+
+Section "OutputClass"
+        Identifier      "starfive display"
+        MatchDriver     "starfive"
+        Option          "PrimaryGPU"    "true"
+EndSection
+
+Section "Monitor"
+        Identifier      "Monitor"
+        # Option                "DPMS"                  "false"
+EndSection
+
+Section "Screen"
+        Identifier      "Screen"
+        Monitor         "Monitor"
+        Device          "Video Device"
+EndSection
+
+Section "ServerLayout"
+        Identifier      "Server Layout"
+        Screen          "Screen"
+EndSection
+
+Section "ServerFlags"
+        Option          "DefaultServerLayout"   "Server Layout"
+
+        # Enable support for DRM format modifiers
+        # Option                "Debug"                 "dmabuf_capable"
+
+        # Disable screen blanking. Disable DPMS in the Monitor section as well.
+        # Option                "BlankTime"             "35790"
+        # Option                "StandbyTime"           "35790"
+        # Option                "SuspendTime"           "35790"
+        # Option                "OffTime"               "35790"
+EndSection

+ 2 - 0
recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend

@@ -0,0 +1,2 @@
+# provide visionfive2 specific X11 config
+FILESEXTRAPATHS:prepend:visionfive2 := "${THISDIR}/${PN}:"

+ 5 - 0
recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend

@@ -0,0 +1,5 @@
+RDEPENDS:${PN}:append:visionfive2 = " \
+    xf86-video-modesetting \
+    ${PN}-extension-glx \
+    xserver-xf86-config \
+"