Browse Source

visionfive2: modules: Fix kernel modules oe_runmake failed
The kernel module's do_compile task require arch/riscv/kernel/vdso/xxx which should be generated when core-image-minimal-initramfs is completed.
Tried to depends on both linux-starfive-dev and make-mod-scripts but sometimes failed, depending on the tasks' racing condition.

Signed-off-by: weiheng.cheng <weiheng.cheng@starfivetech.com>

weiheng.cheng 11 months ago
parent
commit
7a696b7510

+ 1 - 0
recipes-kernel/modules/jpu-module.bb

@@ -18,3 +18,4 @@ SRC_URI += " \
 S = "${WORKDIR}/${JPU_MODULE_SRC}"
 
 RPROVIDES:${PN} += "kernel-module-jpu"
+do_compile[depends] += "core-image-minimal-initramfs:do_image_complete"

+ 1 - 0
recipes-kernel/modules/vdec-module.bb

@@ -20,3 +20,4 @@ S = "${WORKDIR}/${WAVE511_MODULE_SRC}"
 
 RPROVIDES:${PN} += "kernel-module-vdec"
 RDEPENDS:${PN} += "linux-firmware-visionfive2-wave511"
+do_compile[depends] += "core-image-minimal-initramfs:do_image_complete"

+ 1 - 0
recipes-kernel/modules/venc-module.bb

@@ -20,3 +20,4 @@ S = "${WORKDIR}/${WAVE420L_MODULE_SRC}"
 
 RPROVIDES:${PN} += "kernel-module-venc"
 RDEPENDS:${PN} += "linux-firmware-visionfive2-wave420l"
+do_compile[depends] += "core-image-minimal-initramfs:do_image_complete"