Browse Source

u-boot-starfive: Deploy .dtb file required by QEMU
Both Dubhe and JH8100 requires this device tree blob to run QEMU.

Signed-off-by: weiheng.cheng <weiheng.cheng@starfivetech.com>

weiheng.cheng 6 months ago
parent
commit
71c6a1f4c2

BIN
recipes-bsp/u-boot/files/run_qemu_virt.dtb


+ 4 - 0
recipes-bsp/u-boot/u-boot-starfive.bb

@@ -23,6 +23,7 @@ SRCREV:starfive-jh8100 = "94b4b620567e8b87fe9002b5b623043830aff8a8"
 
 SRC_URI:starfive-dubhe = "\
 	git://github.com/${FORK}/u-boot.git;protocol=https;branch=${BRANCH} \
+	file://run_qemu_virt.dtb \
 	"
 
 SRC_URI:starfive-visionfive2 = "\
@@ -37,6 +38,7 @@ SRC_URI:starfive-visionfive2 = "\
 SRC_URI:starfive-jh8100 = "\
 	git://git@192.168.110.45/${FORK}/u-boot.git;protocol=ssh;branch=${BRANCH} \
 	file://tftp-mmc-boot.txt \
+	file://run_qemu_virt.dtb \
 	"
 
 DEPENDS:append:starfive-dubhe = " u-boot-tools-native bmap-tools-native opensbi"
@@ -80,11 +82,13 @@ do_deploy:append:starfive-visionfive2() {
 do_deploy:append:starfive-dubhe() {
     install -m 644 ${WORKDIR}/build/u-boot.itb ${DEPLOYDIR}/u-boot.itb
     rm ${WORKDIR}/build/fw_dynamic.bin
+    install -m 644 ${WORKDIR}/run_qemu_virt.dtb ${DEPLOYDIR}/run_qemu_virt.dtb
 }
 
 do_deploy:append:starfive-jh8100() {
     install -m 644 ${WORKDIR}/build/u-boot.itb ${DEPLOYDIR}/u-boot.itb
     rm ${WORKDIR}/build/fw_dynamic.bin
+    install -m 644 ${WORKDIR}/run_qemu_virt.dtb ${DEPLOYDIR}/run_qemu_virt.dtb
 }
 
 TOOLCHAIN = "gcc"