Преглед изворни кода

dubhe: Added boot code recipe on Dubhe

A recipe is added to deploy boot copier and boot jump code binaries. The
binaries are needed during QSPI Image generation.

Signed-off-by: Jun Yuan Tan <junyuan.tan@starfivetech.com>
Jun Yuan Tan пре 2 година
родитељ
комит
656764cdf0

+ 19 - 0
recipes-bsp/deploy-bootfiles/deploy-bootfiles_0.1.bb

@@ -0,0 +1,19 @@
+SUMMARY = "QSPI Image Creator"
+DESCRIPTION = "Recipe to create a QSPI Image"
+LICENSE = "CLOSED"
+
+LIC_FILES_CHKSUM = ""
+
+SRC_URI = "file://bootcode.bin \
+           file://bootjump.bin \
+          "
+          
+S = "${WORKDIR}"
+
+inherit deploy
+do_deploy(){
+	install -m 755 ${WORKDIR}/bootcode.bin ${DEPLOYDIR}/
+	install -m 755 ${WORKDIR}/bootjump.bin ${DEPLOYDIR}/
+}
+
+addtask deploy before do_build after do_install

BIN
recipes-bsp/deploy-bootfiles/files/bootcode.bin


BIN
recipes-bsp/deploy-bootfiles/files/bootjump.bin