浏览代码

dubhe: images: Add Dubhe 80 support
Standardize image output name & make it machine specific.
.dtb files are renamed as well.

Signed-off-by: weiheng.cheng <weiheng.cheng@starfivetech.com>

weiheng.cheng 7 月之前
父节点
当前提交
530f643254

+ 7 - 4
recipes-core/images/dubhe-image-minimal_0.1.bb

@@ -34,10 +34,13 @@ do_qspi[depends] += " opensbi:do_deploy"
 do_qspi[depends] += " virtual/kernel:do_deploy"
 
 do_qspi (){
-	dd if=${DEPLOY_DIR_IMAGE}/bootcode_min.bin of=${DEPLOY_DIR_IMAGE}/QSPI-EXT4-Image.bin bs=32 seek=0 count=128
-        dd if=${DEPLOY_DIR_IMAGE}/bootjump.bin of=${DEPLOY_DIR_IMAGE}/QSPI-EXT4-Image.bin bs=32 seek=128 count=1
-        dd if=${DEPLOY_DIR_IMAGE}/dubhe_fpga_ext4.dtb of=${DEPLOY_DIR_IMAGE}/QSPI-EXT4-Image.bin bs=32 seek=129 count=255
-        dd if=${DEPLOY_DIR_IMAGE}/fw_payload.bin of=${DEPLOY_DIR_IMAGE}/QSPI-EXT4-Image.bin bs=32 seek=384
+	dd if=${DEPLOY_DIR_IMAGE}/bootcode_min.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ext4-image.bin bs=32 seek=0 count=128
+        dd if=${DEPLOY_DIR_IMAGE}/bootjump.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ext4-image.bin bs=32 seek=128 count=1
+        dd if=${DEPLOY_DIR_IMAGE}/dubhe90_fpga_ext4.dtb of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ext4-image.bin bs=32 seek=129 count=255
+        dd if=${DEPLOY_DIR_IMAGE}/fw_payload.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ext4-image.bin bs=32 seek=384
+
+	cp ${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ext4-image.bin ${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ext4-image.bin
+        dd if=${DEPLOY_DIR_IMAGE}/dubhe80_fpga_ext4.dtb of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ext4-image.bin bs=32 seek=129 count=255
 }
 
 do_sd (){

+ 7 - 4
recipes-core/images/qspi-image_0.1.bb

@@ -16,8 +16,11 @@ do_image[depends] += " opensbi:do_deploy"
 do_image[depends] += " virtual/kernel:do_deploy"
 
 IMAGE_CMD:qspi () {
-	dd if=${DEPLOY_DIR_IMAGE}/bootcode.bin of=${DEPLOY_DIR_IMAGE}/QSPI-Image.bin bs=32 seek=0 count=128
-	dd if=${DEPLOY_DIR_IMAGE}/bootjump.bin of=${DEPLOY_DIR_IMAGE}/QSPI-Image.bin bs=32 seek=128 count=1
-	dd if=${DEPLOY_DIR_IMAGE}/dubhe_fpga.dtb of=${DEPLOY_DIR_IMAGE}/QSPI-Image.bin bs=32 seek=129 count=255
-	dd if=${DEPLOY_DIR_IMAGE}/fw_payload_initramfs.bin of=${DEPLOY_DIR_IMAGE}/QSPI-Image.bin bs=32 seek=384
+	dd if=${DEPLOY_DIR_IMAGE}/bootcode.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-initramfs-image.bin bs=32 seek=0 count=128
+	dd if=${DEPLOY_DIR_IMAGE}/bootjump.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-initramfs-image.bin bs=32 seek=128 count=1
+	dd if=${DEPLOY_DIR_IMAGE}/dubhe90_fpga.dtb of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-initramfs-image.bin bs=32 seek=129 count=255
+	dd if=${DEPLOY_DIR_IMAGE}/fw_payload_initramfs.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-initramfs-image.bin bs=32 seek=384
+
+	cp ${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-initramfs-image.bin ${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-initramfs-image.bin
+        dd if=${DEPLOY_DIR_IMAGE}/dubhe80_fpga.dtb of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-initramfs-image.bin bs=32 seek=129 count=255
 }

+ 7 - 4
recipes-core/images/qspi-nfs-image_0.1.bb

@@ -34,10 +34,13 @@ do_qspi[depends] += " opensbi:do_deploy"
 do_qspi[depends] += " virtual/kernel:do_deploy"
 
 do_qspi (){
-	dd if=${DEPLOY_DIR_IMAGE}/bootcode_min.bin of=${DEPLOY_DIR_IMAGE}/QSPI-NFS-Image.bin bs=32 seek=0 count=128
-        dd if=${DEPLOY_DIR_IMAGE}/bootjump.bin of=${DEPLOY_DIR_IMAGE}/QSPI-NFS-Image.bin bs=32 seek=128 count=1
-        dd if=${DEPLOY_DIR_IMAGE}/dubhe_fpga_nfs.dtb of=${DEPLOY_DIR_IMAGE}/QSPI-NFS-Image.bin bs=32 seek=129 count=255
-        dd if=${DEPLOY_DIR_IMAGE}/fw_payload.bin of=${DEPLOY_DIR_IMAGE}/QSPI-NFS-Image.bin bs=32 seek=384
+	dd if=${DEPLOY_DIR_IMAGE}/bootcode_min.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-nfs-image.bin bs=32 seek=0 count=128
+        dd if=${DEPLOY_DIR_IMAGE}/bootjump.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-nfs-image.bin bs=32 seek=128 count=1
+        dd if=${DEPLOY_DIR_IMAGE}/dubhe90_fpga_nfs.dtb of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-nfs-image.bin bs=32 seek=129 count=255
+        dd if=${DEPLOY_DIR_IMAGE}/fw_payload.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-nfs-image.bin bs=32 seek=384
+
+	cp ${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-nfs-image.bin ${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-nfs-image.bin
+        dd if=${DEPLOY_DIR_IMAGE}/dubhe80_fpga_nfs.dtb of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-nfs-image.bin bs=32 seek=129 count=255
 }
 
 IMAGE_POSTPROCESS_COMMAND += "do_qspi;"

+ 8 - 5
recipes-core/images/qspi-ubifs-image_0.1.bb

@@ -27,11 +27,14 @@ do_qspi[depends] += " opensbi:do_deploy"
 do_qspi[depends] += " virtual/kernel:do_deploy"
 
 do_qspi () {
-        dd if=${DEPLOY_DIR_IMAGE}/bootcode.bin of=${DEPLOY_DIR_IMAGE}/QSPI-Ubifs-Image.bin bs=32 seek=0 count=128
-        dd if=${DEPLOY_DIR_IMAGE}/bootjump.bin of=${DEPLOY_DIR_IMAGE}/QSPI-Ubifs-Image.bin bs=32 seek=128 count=1
-        dd if=${DEPLOY_DIR_IMAGE}/dubhe_fpga_ubi.dtb of=${DEPLOY_DIR_IMAGE}/QSPI-Ubifs-Image.bin bs=32 seek=129 count=255
-        dd if=${DEPLOY_DIR_IMAGE}/fw_payload.bin of=${DEPLOY_DIR_IMAGE}/QSPI-Ubifs-Image.bin bs=32 seek=384 count=1048192
-	dd if=${IMGDEPLOYDIR}/qspi-ubifs-starfive-dubhe.ubi of=${DEPLOY_DIR_IMAGE}/QSPI-Ubifs-Image.bin bs=64KiB seek=512
+        dd if=${DEPLOY_DIR_IMAGE}/bootcode.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ubifs-image.bin bs=32 seek=0 count=128
+        dd if=${DEPLOY_DIR_IMAGE}/bootjump.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ubifs-image.bin bs=32 seek=128 count=1
+        dd if=${DEPLOY_DIR_IMAGE}/dubhe90_fpga_ubi.dtb of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ubifs-image.bin bs=32 seek=129 count=255
+        dd if=${DEPLOY_DIR_IMAGE}/fw_payload.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ubifs-image.bin bs=32 seek=384 count=1048192
+	dd if=${IMGDEPLOYDIR}/qspi-ubifs-starfive-dubhe.ubi of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ubifs-image.bin bs=64KiB seek=512
+
+	cp ${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ubifs-image.bin ${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ubifs-image.bin
+        dd if=${DEPLOY_DIR_IMAGE}/dubhe80_fpga_ubi.dtb of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ubifs-image.bin bs=32 seek=129 count=255
 }
 
 IMAGE_POSTPROCESS_COMMAND += "do_qspi;"