Browse Source

visionfive2: core-image-minimal-xfce: Install packages & generate image
Install all kernel modules, vpu and some packages. Move SD image generation task to sd-image.inc file.

Signed-off-by: weiheng.cheng <weiheng.cheng@starfivetech.com>

weiheng.cheng 11 months ago
parent
commit
3b4eedf672

+ 29 - 0
recipes-core/images/core-image-minimal-xfce.bbappend

@@ -0,0 +1,29 @@
+require sd-image.inc
+
+DEPENDS += " opensbi starfive-tool-native u-boot-tools-native dtc-native"
+
+IMAGE_INSTALL += " \
+	helloworld \
+	coremark \
+	dhrystone \
+	perf \
+	gdb \
+	gdbserver \
+	util-linux \
+	ethtool \
+	bmap-tools \
+	systemd-analyze \
+	e2fsprogs-resize2fs \
+	mesa-pvr \
+	visionfive2-pvr-graphics \
+	glmark2 \
+	ffmpeg \
+	libsf-codaj12 \
+	libsf-omxil \
+	libsf-wave420l \
+	libsf-wave511 \
+	jpu-module \
+	vdec-module \
+	venc-module \
+	openssh \
+	"

+ 10 - 0
recipes-core/images/sd-image.inc

@@ -0,0 +1,10 @@
+# Generate SD Card image and eMMC image
+# - Using spl_tool to fix img header to boot from eMMC
+
+do_vf2_sd (){
+        cd ${IMGDEPLOYDIR}
+        bmaptool copy ${PN}-${MACHINE}.wic.gz ${DEPLOY_DIR_IMAGE}/${MACHINE}-${PN}.img
+        spl_tool -i -f ${DEPLOY_DIR_IMAGE}/${MACHINE}-${PN}.img
+}
+
+IMAGE_POSTPROCESS_COMMAND:starfive-visionfive2 += "do_vf2_sd;"