ソースを参照

starfive: binutils: Update binutils to support B extension

B extension support is needed after updating GCC with B extension. This
updates the binutils to use the branch and repo that supports B extension

Signed-off-by: Tien Hock Loh <tienhock.loh@starfivetech.com>
Tien Hock Loh 2 年 前
コミット
30a1c826fd

+ 11 - 0
recipes-devtools/binutils/binutils-cross-canadian_2.36.bbappend

@@ -0,0 +1,11 @@
+SRCBRANCH = "sifive-rvv-1.0.x-zfh-rvb"
+
+SRCREV = "75d2236ce26a3048f52bbd5186602e27bd635e2b"
+
+BINUTILS_GIT_URI = "git://github.com/sifive/riscv-binutils-gdb.git;branch=${SRCBRANCH};protocol=git"
+
+SRC_URI = "\
+      ${BINUTILS_GIT_URI} \
+      file://0005-Point-scripts-location-to-libdir.patch \
+"
+

+ 11 - 0
recipes-devtools/binutils/binutils-cross_2.36.bbappend

@@ -0,0 +1,11 @@
+SRCBRANCH = "sifive-rvv-1.0.x-zfh-rvb"
+
+SRCREV = "75d2236ce26a3048f52bbd5186602e27bd635e2b"
+
+BINUTILS_GIT_URI = "git://github.com/sifive/riscv-binutils-gdb.git;branch=${SRCBRANCH};protocol=git"
+
+SRC_URI = "\
+      ${BINUTILS_GIT_URI} \
+      file://0005-Point-scripts-location-to-libdir.patch \
+"
+

+ 11 - 0
recipes-devtools/binutils/binutils-crosssdk_2.36.bbappend

@@ -0,0 +1,11 @@
+SRCBRANCH = "sifive-rvv-1.0.x-zfh-rvb"
+
+SRCREV = "75d2236ce26a3048f52bbd5186602e27bd635e2b"
+
+BINUTILS_GIT_URI = "git://github.com/sifive/riscv-binutils-gdb.git;branch=${SRCBRANCH};protocol=git"
+
+SRC_URI = "\
+      ${BINUTILS_GIT_URI} \
+      file://0005-Point-scripts-location-to-libdir.patch \
+"
+

+ 39 - 0
recipes-devtools/binutils/binutils/0005-Point-scripts-location-to-libdir.patch

@@ -0,0 +1,39 @@
+From 6a67d277941228d997b527990960413f8444fb81 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 2 Mar 2015 01:09:58 +0000
+Subject: [PATCH] Point scripts location to libdir
+
+Upstream-Status: Inappropriate [debian patch]
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ ld/Makefile.am | 2 +-
+ ld/Makefile.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/ld/Makefile.am b/ld/Makefile.am
+index 3b01357b651..b7a1f7491b0 100644
+--- a/ld/Makefile.am
++++ b/ld/Makefile.am
+@@ -51,7 +51,7 @@ AM_CFLAGS = $(WARN_CFLAGS) $(ELF_CLFAGS)
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+ 
+ EMUL = @EMUL@
+ EMULATION_OFILES = @EMULATION_OFILES@
+diff --git a/ld/Makefile.in b/ld/Makefile.in
+index a6382bf2a45..5ee3a4971be 100644
+--- a/ld/Makefile.in
++++ b/ld/Makefile.in
+@@ -562,7 +562,7 @@ AM_CFLAGS = $(WARN_CFLAGS) $(ELF_CLFAGS)
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+ BASEDIR = $(srcdir)/..
+ BFDDIR = $(BASEDIR)/bfd
+ INCDIR = $(BASEDIR)/include

+ 11 - 0
recipes-devtools/binutils/binutils_2.36.bbappend

@@ -0,0 +1,11 @@
+SRCBRANCH = "sifive-rvv-1.0.x-zfh-rvb"
+
+SRCREV = "75d2236ce26a3048f52bbd5186602e27bd635e2b"
+
+BINUTILS_GIT_URI = "git://github.com/sifive/riscv-binutils-gdb.git;branch=${SRCBRANCH};protocol=git"
+
+SRC_URI = "\
+      ${BINUTILS_GIT_URI} \
+      file://0005-Point-scripts-location-to-libdir.patch \
+"
+