Browse Source

dubhe: Added sample helloworld recipe on Dubhe

Added a simple helloworld recipe as an initial guideline for new recipe
generation.

Signed-off-by: Jun Yuan Tan <junyuan.tan@starfivetech.com>
Jun Yuan Tan 2 years ago
parent
commit
25a81b82ef

+ 6 - 0
recipes-extended/helloworld/files/helloworld.c

@@ -0,0 +1,6 @@
+#include <stdio.h>
+
+int main(){
+	printf("Hello World!!!\n");
+	return 0;
+}

+ 19 - 0
recipes-extended/helloworld/helloworld_0.1.bb

@@ -0,0 +1,19 @@
+SUMMARY = "Hello World recipe"
+DESCRIPTION = "Sample helloworld recipe"
+LICENSE = "CLOSED"
+
+LIC_FILES_CHKSUM = ""
+
+SRC_URI = "file://helloworld.c \
+	"
+
+S = "${WORKDIR}"
+
+do_compile(){
+	${CC} ${CFLAGS} ${LDFLAGS} helloworld.c -o helloworld
+}
+
+do_install(){
+	install -d ${D}${bindir}
+	install -m 0755 helloworld ${D}${bindir}
+}