Browse Source

modules: Add modules to build target

Fixes parallel build issue
| fixdep: error opening file: arch/riscv/kernel/vdso/.rt_sigreturn.o.d: No such file or directory

Patch from meta-riscv commit 6e0d7361adf3f4198b7484a4aa5a56a1f370f567
Jun Yuan Tan 6 months ago
parent
commit
071e88b233

+ 1 - 1
recipes-kernel/modules/jpu-module/Makefile

@@ -6,7 +6,7 @@ obj-m := jpu.o
 SRC := $(shell pwd)
 
 all:
-	$(MAKE) -C $(KERNEL_SRC) M=$(SRC)
+	$(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules
 
 modules_install:
 	$(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install

+ 1 - 1
recipes-kernel/modules/vdec-module/Makefile

@@ -6,7 +6,7 @@ obj-m := vdec.o
 SRC := $(shell pwd)
 
 all:
-	$(MAKE) -C $(KERNEL_SRC) M=$(SRC)
+	$(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules
 
 modules_install:
 	$(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install

+ 1 - 1
recipes-kernel/modules/venc-module/Makefile

@@ -6,7 +6,7 @@ obj-m := venc.o
 SRC := $(shell pwd)
 
 all:
-	$(MAKE) -C $(KERNEL_SRC) M=$(SRC)
+	$(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules
 
 modules_install:
 	$(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install