znc.mk 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. ################################################################################
  2. #
  3. # znc
  4. #
  5. ################################################################################
  6. ZNC_VERSION = 1.8.2
  7. ZNC_SITE = http://znc.in/releases/archive
  8. ZNC_LICENSE = Apache-2.0
  9. ZNC_LICENSE_FILES = LICENSE
  10. ZNC_DEPENDENCIES = host-pkgconf
  11. ZNC_CONF_OPTS = -DWANT_CYRUS=OFF -DWANT_I18N=OFF -DWANT_PERL=OFF
  12. # Before CMake 3.10, passing THREADS_PTHREAD_ARG=OFF was needed to
  13. # disable a try_run() call in the FindThreads tests, which caused a
  14. # build failure when cross-compiling.
  15. ZNC_CONF_OPTS += -DTHREADS_PTHREAD_ARG=OFF
  16. ifeq ($(BR2_PACKAGE_ICU),y)
  17. ZNC_DEPENDENCIES += icu
  18. ZNC_CONF_OPTS += -DWANT_ICU=ON
  19. else
  20. ZNC_CONF_OPTS += -DWANT_ICU=OFF
  21. endif
  22. ifeq ($(BR2_PACKAGE_OPENSSL),y)
  23. ZNC_DEPENDENCIES += openssl
  24. ZNC_CONF_OPTS += -DWANT_OPENSSL=ON
  25. else
  26. ZNC_CONF_OPTS += -DWANT_OPENSSL=OFF
  27. endif
  28. ifeq ($(BR2_PACKAGE_ZLIB),y)
  29. ZNC_DEPENDENCIES += zlib
  30. ZNC_CONF_OPTS += -DWANT_ZLIB=ON
  31. else
  32. ZNC_CONF_OPTS += -DWANT_ZLIB=OFF
  33. endif
  34. # python support depends on icu
  35. ifeq ($(BR2_PACKAGE_ICU)$(BR2_PACKAGE_PYTHON3),yy)
  36. ZNC_DEPENDENCIES += python3 host-swig
  37. ZNC_CONF_OPTS += \
  38. -DWANT_PYTHON=ON \
  39. -DWANT_PYTHON_VERSION=python3 \
  40. -DWANT_SWIG=ON
  41. else
  42. ZNC_CONF_OPTS += \
  43. -DWANT_PYTHON=OFF \
  44. -DWANT_SWIG=OFF
  45. endif
  46. $(eval $(cmake-package))