yasm.mk 765 B

12345678910111213141516171819202122
  1. ################################################################################
  2. #
  3. # yasm
  4. #
  5. ################################################################################
  6. YASM_VERSION = 1.3.0
  7. YASM_SITE = http://www.tortall.net/projects/yasm/releases
  8. YASM_LICENSE = BSD-2-Clause, BSD-3-Clause, Artistic, GPL-2.0, LGPL-2.0
  9. YASM_LICENSE_FILES = COPYING BSD.txt Artistic.txt GNU_GPL-2.0 GNU_LGPL-2.0
  10. # This sed prevents it compiling 2 programs (vsyasm and ytasm)
  11. # that are only of use on Microsoft Windows.
  12. define YASM_PRE_CONFIGURE_FIXUP
  13. $(SED) 's#) ytasm.*#)#' $(@D)/Makefile.in
  14. endef
  15. YASM_PRE_CONFIGURE_HOOKS += YASM_PRE_CONFIGURE_FIXUP
  16. HOST_YASM_PRE_CONFIGURE_HOOKS += YASM_PRE_CONFIGURE_FIXUP
  17. $(eval $(autotools-package))
  18. $(eval $(host-autotools-package))