wireless_tools.mk 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. ################################################################################
  2. #
  3. # wireless_tools
  4. #
  5. ################################################################################
  6. WIRELESS_TOOLS_VERSION_MAJOR = 30
  7. WIRELESS_TOOLS_VERSION = $(WIRELESS_TOOLS_VERSION_MAJOR).pre9
  8. WIRELESS_TOOLS_SITE = https://hewlettpackard.github.io/wireless-tools
  9. WIRELESS_TOOLS_SOURCE = wireless_tools.$(WIRELESS_TOOLS_VERSION).tar.gz
  10. WIRELESS_TOOLS_LICENSE = GPL-2.0
  11. WIRELESS_TOOLS_LICENSE_FILES = COPYING
  12. WIRELESS_TOOLS_INSTALL_STAGING = YES
  13. WIRELESS_TOOLS_BUILD_TARGETS = iwmulticall
  14. WIRELESS_TOOLS_INSTALL_TARGETS = install-iwmulticall
  15. ifeq ($(BR2_PACKAGE_WIRELESS_TOOLS_LIB),y)
  16. WIRELESS_TOOLS_BUILD_TARGETS += libiw.so.$(WIRELESS_TOOLS_VERSION_MAJOR)
  17. WIRELESS_TOOLS_INSTALL_TARGETS += install-dynamic
  18. define WIRELESS_TOOLS_INSTALL_STAGING_CMDS
  19. $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) PREFIX="$(STAGING_DIR)" LDCONFIG=/bin/true \
  20. install-dynamic
  21. $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) PREFIX="$(STAGING_DIR)/usr" install-hdr
  22. endef
  23. endif
  24. define WIRELESS_TOOLS_BUILD_CMDS
  25. $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
  26. $(WIRELESS_TOOLS_BUILD_TARGETS)
  27. endef
  28. define WIRELESS_TOOLS_INSTALL_TARGET_CMDS
  29. $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) PREFIX="$(TARGET_DIR)" LDCONFIG=/bin/true \
  30. $(WIRELESS_TOOLS_INSTALL_TARGETS)
  31. endef
  32. $(eval $(generic-package))