waylandpp.mk 964 B

12345678910111213141516171819202122232425262728
  1. ################################################################################
  2. #
  3. # waylandpp
  4. #
  5. ################################################################################
  6. WAYLANDPP_VERSION = 0.2.8
  7. WAYLANDPP_SITE = $(call github,NilsBrause,waylandpp,$(WAYLANDPP_VERSION))
  8. WAYLANDPP_LICENSE = MIT, GPL-3.0+ (wayland_scanner)
  9. WAYLANDPP_LICENSE_FILES = LICENSE scanner/gpl-3.0.txt
  10. WAYLANDPP_INSTALL_STAGING = YES
  11. # pugixml is needed only to build the host version of wayland-scanner++
  12. HOST_WAYLANDPP_DEPENDENCIES = host-pugixml host-pkgconf host-wayland
  13. WAYLANDPP_DEPENDENCIES = libegl host-pkgconf wayland host-waylandpp
  14. # host variant of wayland-scanner++ is needed for building the target
  15. # package
  16. HOST_WAYLANDPP_CONF_OPTS = \
  17. -DBUILD_LIBRARIES=OFF \
  18. -DBUILD_SCANNER=ON
  19. WAYLANDPP_CONF_OPTS = \
  20. -DBUILD_LIBRARIES=ON \
  21. -DBUILD_SCANNER=OFF \
  22. -DWAYLAND_SCANNERPP=$(HOST_DIR)/bin/wayland-scanner++
  23. $(eval $(cmake-package))
  24. $(eval $(host-cmake-package))