wayland.mk 912 B

1234567891011121314151617181920212223242526
  1. ################################################################################
  2. #
  3. # wayland
  4. #
  5. ################################################################################
  6. WAYLAND_VERSION = 1.18.0
  7. WAYLAND_SITE = https://wayland.freedesktop.org/releases
  8. WAYLAND_SOURCE = wayland-$(WAYLAND_VERSION).tar.xz
  9. WAYLAND_LICENSE = MIT
  10. WAYLAND_LICENSE_FILES = COPYING
  11. WAYLAND_INSTALL_STAGING = YES
  12. WAYLAND_DEPENDENCIES = host-pkgconf host-wayland expat libffi libxml2
  13. HOST_WAYLAND_DEPENDENCIES = host-pkgconf host-expat host-libffi host-libxml2
  14. WAYLAND_CONF_OPTS = -Dtests=false -Ddocumentation=false
  15. HOST_WAYLAND_CONF_OPTS = -Dtests=false -Ddocumentation=false
  16. # Remove the DTD from the target, it's not needed at runtime
  17. define WAYLAND_TARGET_CLEANUP
  18. rm -rf $(TARGET_DIR)/usr/share/wayland
  19. endef
  20. WAYLAND_POST_INSTALL_TARGET_HOOKS += WAYLAND_TARGET_CLEANUP
  21. $(eval $(meson-package))
  22. $(eval $(host-meson-package))