wavpack.mk 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. ################################################################################
  2. #
  3. # wavpack
  4. #
  5. ################################################################################
  6. WAVPACK_VERSION = 5.3.0
  7. WAVPACK_SITE = \
  8. https://github.com/dbry/WavPack/releases/download/$(WAVPACK_VERSION)
  9. WAVPACK_SOURCE = wavpack-$(WAVPACK_VERSION).tar.xz
  10. WAVPACK_INSTALL_STAGING = YES
  11. WAVPACK_DEPENDENCIES = $(if $(BR2_ENABLE_LOCALE),,libiconv)
  12. WAVPACK_LICENSE = BSD-3-Clause
  13. WAVPACK_LICENSE_FILES = COPYING
  14. ifeq ($(BR2_PACKAGE_LIBICONV),y)
  15. WAVPACK_CONF_OPTS += LIBS=-liconv
  16. endif
  17. ifeq ($(BR2_PACKAGE_OPENSSL),y)
  18. WAVPACK_DEPENDENCIES += openssl
  19. WAVPACK_CONF_OPTS += --enable-libcrypto
  20. else
  21. WAVPACK_CONF_OPTS += --disable-libcrypto
  22. endif
  23. # WavPack "autodetects" CPU type to enable ASM code. However, the assembly code
  24. # for ARM is written for ARMv7 only and building WavPack for an ARM-non-v7
  25. # architecture will fail. We explicitly enable ASM for the supported
  26. # architectures x86, x64 and ARMv7 and disable it for all others.
  27. ifeq ($(BR2_i386)$(BR2_x86_64)$(BR2_ARM_CPU_ARMV7A),y)
  28. WAVPACK_CONF_OPTS += --enable-asm
  29. else
  30. WAVPACK_CONF_OPTS += --disable-asm
  31. endif
  32. $(eval $(autotools-package))