vorbis-tools.mk 1.0 KB

1234567891011121314151617181920212223242526272829303132
  1. ################################################################################
  2. #
  3. # vorbis-tools
  4. #
  5. ################################################################################
  6. VORBIS_TOOLS_VERSION = 1.4.0
  7. VORBIS_TOOLS_SITE = http://downloads.xiph.org/releases/vorbis
  8. VORBIS_TOOLS_LICENSE = GPL-2.0
  9. VORBIS_TOOLS_LICENSE_FILES = COPYING
  10. VORBIS_TOOLS_DEPENDENCIES = libao libogg libvorbis libcurl
  11. VORBIS_TOOLS_CONF_OPTS = --program-transform-name=''
  12. # 0001-oggenc-Fix-large-alloca-on-bad-AIFF-input.patch
  13. VORBIS_TOOLS_IGNORE_CVES += CVE-2015-6749
  14. # 0002-oggenc-validate-count-of-channels-in-the-header-CVE-.patch
  15. VORBIS_TOOLS_IGNORE_CVES += CVE-2014-9638 CVE-2014-9639
  16. # 0003-oggenc-fix-crash-on-raw-file-close-reported-by-Hanno.patch
  17. VORBIS_TOOLS_IGNORE_CVES += CVE-2014-9640
  18. # ogg123 calls math functions but forgets to link with libm
  19. VORBIS_TOOLS_CONF_ENV = LIBS=-lm
  20. ifeq ($(BR2_PACKAGE_FLAC),y)
  21. VORBIS_TOOLS_DEPENDENCIES += flac
  22. endif
  23. ifeq ($(BR2_PACKAGE_SPEEX),y)
  24. VORBIS_TOOLS_DEPENDENCIES += speex
  25. endif
  26. $(eval $(autotools-package))