vmtouch.mk 565 B

123456789101112131415161718192021
  1. ################################################################################
  2. #
  3. # vmtouch
  4. #
  5. ################################################################################
  6. VMTOUCH_VERSION = 1.3.1
  7. VMTOUCH_SITE = $(call github,hoytech,vmtouch,v$(VMTOUCH_VERSION))
  8. VMTOUCH_LICENSE = BSD-3-Clause
  9. VMTOUCH_LICENSE_FILES = LICENSE
  10. define VMTOUCH_BUILD_CMDS
  11. $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
  12. endef
  13. define VMTOUCH_INSTALL_TARGET_CMDS
  14. $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) install \
  15. DESTDIR=$(TARGET_DIR) PREFIX=/usr
  16. endef
  17. $(eval $(generic-package))