vlc.mk 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583
  1. ################################################################################
  2. #
  3. # vlc
  4. #
  5. ################################################################################
  6. VLC_VERSION = 3.0.11
  7. VLC_SITE = https://get.videolan.org/vlc/$(VLC_VERSION)
  8. VLC_SOURCE = vlc-$(VLC_VERSION).tar.xz
  9. VLC_LICENSE = GPL-2.0+, LGPL-2.1+
  10. VLC_LICENSE_FILES = COPYING COPYING.LIB
  11. VLC_DEPENDENCIES = host-pkgconf
  12. VLC_AUTORECONF = YES
  13. # Install vlc libraries in staging.
  14. VLC_INSTALL_STAGING = YES
  15. # gcc bug internal compiler error: in merge_overlapping_regs, at
  16. # regrename.c:304. This bug is fixed since gcc 6.
  17. ifeq ($(BR2_microblaze)$(BR2_or1k):$(BR2_TOOLCHAIN_GCC_AT_LEAST_6),y:)
  18. VLC_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -O0"
  19. VLC_CONF_OPTS += --disable-optimizations
  20. endif
  21. # configure check for -fstack-protector-strong is broken
  22. VLC_CONF_ENV += \
  23. ax_cv_check_cflags___fstack_protector_strong=$(if $(BR2_TOOLCHAIN_HAS_SSP),yes,no)
  24. # VLC defines two autoconf functions which are also defined by our own pkg.m4
  25. # from pkgconf. Unfortunately, they are defined in a different way: VLC adds
  26. # --enable- options, but pkg.m4 adds --with- options. To make sure we use
  27. # VLC's definition, rename these two functions.
  28. define VLC_OVERRIDE_PKG_M4
  29. $(SED) 's/PKG_WITH_MODULES/VLC_PKG_WITH_MODULES/g' \
  30. -e 's/PKG_HAVE_WITH_MODULES/VLC_PKG_HAVE_WITH_MODULES/g' \
  31. $(@D)/configure.ac $(@D)/m4/with_pkg.m4
  32. endef
  33. VLC_POST_PATCH_HOOKS += VLC_OVERRIDE_PKG_M4
  34. VLC_CONF_OPTS += \
  35. --disable-a52 \
  36. --disable-addonmanagermodules \
  37. --disable-aom \
  38. --disable-aribb25 \
  39. --disable-aribsub \
  40. --disable-asdcp \
  41. --disable-bpg \
  42. --disable-caca \
  43. --disable-chromaprint \
  44. --disable-chromecast \
  45. --disable-crystalhd \
  46. --disable-dc1394 \
  47. --disable-dca \
  48. --disable-decklink \
  49. --disable-dsm \
  50. --disable-dv1394 \
  51. --disable-fluidlite \
  52. --disable-gme \
  53. --disable-goom \
  54. --disable-jack \
  55. --disable-jpeg \
  56. --disable-kai \
  57. --disable-kate \
  58. --disable-kva \
  59. --disable-libplacebo \
  60. --disable-linsys \
  61. --disable-mfx \
  62. --disable-microdns \
  63. --disable-mmal \
  64. --disable-mtp \
  65. --disable-notify \
  66. --disable-projectm \
  67. --disable-schroedinger \
  68. --disable-shine \
  69. --disable-shout \
  70. --disable-sndio \
  71. --disable-spatialaudio \
  72. --disable-srt \
  73. --disable-telx \
  74. --disable-tiger \
  75. --disable-twolame \
  76. --disable-vdpau \
  77. --disable-vsxu \
  78. --disable-wasapi \
  79. --disable-x262 \
  80. --disable-zvbi \
  81. --enable-run-as-root
  82. # Uses __atomic_fetch_add_4
  83. ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
  84. VLC_CONF_ENV += LIBS="-latomic"
  85. endif
  86. # Building static and shared doesn't work, so force static off.
  87. ifeq ($(BR2_STATIC_LIBS),)
  88. VLC_CONF_OPTS += --disable-static
  89. endif
  90. ifeq ($(BR2_POWERPC_CPU_HAS_ALTIVEC),y)
  91. VLC_CONF_OPTS += --enable-altivec
  92. else
  93. VLC_CONF_OPTS += --disable-altivec
  94. endif
  95. ifeq ($(BR2_X86_CPU_HAS_SSE),y)
  96. VLC_CONF_OPTS += --enable-sse
  97. else
  98. VLC_CONF_OPTS += --disable-sse
  99. endif
  100. ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
  101. VLC_CONF_OPTS += --enable-alsa
  102. VLC_DEPENDENCIES += alsa-lib
  103. else
  104. VLC_CONF_OPTS += --disable-alsa
  105. endif
  106. # avahi support needs avahi-client, which needs avahi-daemon and dbus
  107. ifeq ($(BR2_PACKAGE_AVAHI)$(BR2_PACKAGE_AVAHI_DAEMON)$(BR2_PACKAGE_DBUS),yyy)
  108. VLC_CONF_OPTS += --enable-avahi
  109. VLC_DEPENDENCIES += avahi
  110. else
  111. VLC_CONF_OPTS += --disable-avahi
  112. endif
  113. ifeq ($(BR2_PACKAGE_DAV1D),y)
  114. VLC_CONF_OPTS += --enable-dav1d
  115. VLC_DEPENDENCIES += dav1d
  116. else
  117. VLC_CONF_OPTS += --disable-dav1d
  118. endif
  119. ifeq ($(BR2_PACKAGE_DBUS),y)
  120. VLC_CONF_OPTS += --enable-dbus
  121. VLC_DEPENDENCIES += dbus
  122. else
  123. VLC_CONF_OPTS += --disable-dbus
  124. endif
  125. ifeq ($(BR2_PACKAGE_FAAD2),y)
  126. VLC_CONF_OPTS += --enable-faad
  127. VLC_DEPENDENCIES += faad2
  128. else
  129. VLC_CONF_OPTS += --disable-faad
  130. endif
  131. ifeq ($(BR2_PACKAGE_FFMPEG),y)
  132. VLC_CONF_OPTS += --enable-avcodec
  133. VLC_DEPENDENCIES += ffmpeg
  134. else
  135. VLC_CONF_OPTS += --disable-avcodec
  136. endif
  137. ifeq ($(BR2_PACKAGE_FFMPEG_POSTPROC),y)
  138. VLC_CONF_OPTS += --enable-postproc
  139. else
  140. VLC_CONF_OPTS += --disable-postproc
  141. endif
  142. ifeq ($(BR2_PACKAGE_FFMPEG_SWSCALE),y)
  143. VLC_CONF_OPTS += --enable-swscale
  144. else
  145. VLC_CONF_OPTS += --disable-swscale
  146. endif
  147. ifeq ($(BR2_PACKAGE_FLAC),y)
  148. VLC_CONF_OPTS += --enable-flac
  149. VLC_DEPENDENCIES += flac
  150. else
  151. VLC_CONF_OPTS += --disable-flac
  152. endif
  153. ifeq ($(BR2_PACKAGE_FLUIDSYNTH),y)
  154. VLC_CONF_OPTS += --enable-fluidsynth
  155. VLC_DEPENDENCIES += fluidsynth
  156. else
  157. VLC_CONF_OPTS += --disable-fluidsynth
  158. endif
  159. ifeq ($(BR2_PACKAGE_FREERDP),y)
  160. VLC_CONF_OPTS += --enable-freerdp
  161. VLC_DEPENDENCIES += freerdp
  162. else
  163. VLC_CONF_OPTS += --disable-freerdp
  164. endif
  165. ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BASE),y)
  166. VLC_CONF_OPTS += --enable-gst-decode
  167. VLC_DEPENDENCIES += gst1-plugins-base
  168. else
  169. VLC_CONF_OPTS += --disable-gst-decode
  170. endif
  171. ifeq ($(BR2_PACKAGE_HAS_LIBGL),y)
  172. VLC_DEPENDENCIES += libgl
  173. endif
  174. ifeq ($(BR2_PACKAGE_HARFBUZZ),y)
  175. VLC_CONF_OPTS += --enable-harfbuzz
  176. VLC_DEPENDENCIES += harfbuzz
  177. else
  178. VLC_CONF_OPTS += --disable-harfbuzz
  179. endif
  180. ifeq ($(BR2_PACKAGE_HAS_LIBGLES),y)
  181. VLC_CONF_OPTS += --enable-gles2
  182. VLC_DEPENDENCIES += libgles
  183. else
  184. VLC_CONF_OPTS += --disable-gles2
  185. endif
  186. ifeq ($(BR2_PACKAGE_OPENCV3),y)
  187. VLC_CONF_OPTS += --enable-opencv
  188. VLC_DEPENDENCIES += opencv3
  189. else
  190. VLC_CONF_OPTS += --disable-opencv
  191. endif
  192. ifeq ($(BR2_PACKAGE_OPUS),y)
  193. VLC_CONF_OPTS += --enable-opus
  194. VLC_DEPENDENCIES += libvorbis opus
  195. else
  196. VLC_CONF_OPTS += --disable-opus
  197. endif
  198. ifeq ($(BR2_PACKAGE_LIBARCHIVE),y)
  199. VLC_CONF_OPTS += --enable-archive
  200. VLC_DEPENDENCIES += libarchive
  201. else
  202. VLC_CONF_OPTS += --disable-archive
  203. endif
  204. ifeq ($(BR2_PACKAGE_LIBASS),y)
  205. VLC_CONF_OPTS += --enable-libass
  206. VLC_DEPENDENCIES += libass
  207. else
  208. VLC_CONF_OPTS += --disable-libass
  209. endif
  210. ifeq ($(BR2_PACKAGE_LIBBLURAY),y)
  211. VLC_CONF_OPTS += --enable-bluray
  212. VLC_DEPENDENCIES += libbluray
  213. else
  214. VLC_CONF_OPTS += --disable-bluray
  215. endif
  216. ifeq ($(BR2_PACKAGE_LIBCDDB),y)
  217. VLC_CONF_OPTS += --enable-libcddb
  218. VLC_DEPENDENCIES += libcddb
  219. else
  220. VLC_CONF_OPTS += --disable-libcddb
  221. endif
  222. ifeq ($(BR2_PACKAGE_LIBDVBPSI),y)
  223. VLC_CONF_OPTS += --enable-dvbpsi
  224. VLC_DEPENDENCIES += libdvbpsi
  225. else
  226. VLC_CONF_OPTS += --disable-dvbpsi
  227. endif
  228. ifeq ($(BR2_PACKAGE_LIBDVDNAV),y)
  229. VLC_CONF_OPTS += --enable-dvdnav
  230. VLC_DEPENDENCIES += libdvdnav
  231. else
  232. VLC_CONF_OPTS += --disable-dvdnav
  233. endif
  234. ifeq ($(BR2_PACKAGE_LIBDVDREAD),y)
  235. VLC_CONF_OPTS += --enable-dvdread
  236. VLC_DEPENDENCIES += libdvdread
  237. else
  238. VLC_CONF_OPTS += --disable-dvdread
  239. endif
  240. ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
  241. VLC_CONF_OPTS += --enable-libgcrypt
  242. VLC_DEPENDENCIES += libgcrypt
  243. VLC_CONF_ENV += \
  244. GCRYPT_CONFIG="$(STAGING_DIR)/usr/bin/libgcrypt-config"
  245. else
  246. VLC_CONF_OPTS += --disable-libgcrypt
  247. endif
  248. ifeq ($(BR2_PACKAGE_LIBIDN),y)
  249. VLC_DEPENDENCIES += libidn
  250. endif
  251. ifeq ($(BR2_PACKAGE_LIBMAD),y)
  252. VLC_CONF_OPTS += --enable-mad
  253. VLC_DEPENDENCIES += libmad
  254. else
  255. VLC_CONF_OPTS += --disable-mad
  256. endif
  257. ifeq ($(BR2_PACKAGE_LIBMATROSKA),y)
  258. VLC_CONF_OPTS += --enable-matroska
  259. VLC_DEPENDENCIES += libmatroska
  260. else
  261. VLC_CONF_OPTS += --disable-matroska
  262. endif
  263. ifeq ($(BR2_PACKAGE_LIBMODPLUG),y)
  264. VLC_CONF_OPTS += --enable-mod
  265. VLC_DEPENDENCIES += libmodplug
  266. else
  267. VLC_CONF_OPTS += --disable-mod
  268. endif
  269. ifeq ($(BR2_PACKAGE_LIBMPEG2),y)
  270. VLC_CONF_OPTS += --enable-libmpeg2
  271. VLC_DEPENDENCIES += libmpeg2
  272. else
  273. VLC_CONF_OPTS += --disable-libmpeg2
  274. endif
  275. ifeq ($(BR2_PACKAGE_LIBNFS),y)
  276. VLC_CONF_OPTS += --enable-nfs
  277. VLC_DEPENDENCIES += libnfs
  278. else
  279. VLC_CONF_OPTS += --disable-nfs
  280. endif
  281. ifeq ($(BR2_PACKAGE_LIBPNG),y)
  282. VLC_CONF_OPTS += --enable-png
  283. VLC_DEPENDENCIES += libpng
  284. else
  285. VLC_CONF_OPTS += --disable-png
  286. endif
  287. ifeq ($(BR2_PACKAGE_LIBRSVG),y)
  288. VLC_CONF_OPTS += --enable-svg --enable-svgdec
  289. VLC_DEPENDENCIES += librsvg
  290. else
  291. VLC_CONF_OPTS += --disable-svg --disable-svgdec
  292. endif
  293. ifeq ($(BR2_PACKAGE_LIBSAMPLERATE),y)
  294. VLC_CONF_OPTS += --enable-samplerate
  295. VLC_DEPENDENCIES += libsamplerate
  296. else
  297. VLC_CONF_OPTS += --disable-samplerate
  298. endif
  299. ifeq ($(BR2_PACKAGE_LIBSECRET),y)
  300. VLC_CONF_OPTS += --enable-secret
  301. VLC_DEPENDENCIES += libsecret
  302. else
  303. VLC_CONF_OPTS += --disable-secret
  304. endif
  305. ifeq ($(BR2_PACKAGE_LIBSOXR),y)
  306. VLC_CONF_OPTS += --enable-soxr
  307. VLC_DEPENDENCIES += libsoxr
  308. else
  309. VLC_CONF_OPTS += --disable-soxr
  310. endif
  311. ifeq ($(BR2_PACKAGE_LIBSSH2),y)
  312. VLC_CONF_OPTS += --enable-sftp
  313. VLC_DEPENDENCIES += libssh2
  314. else
  315. VLC_CONF_OPTS += --disable-sftp
  316. endif
  317. ifeq ($(BR2_PACKAGE_LIBSIDPLAY2),y)
  318. VLC_CONF_OPTS += --enable-sid
  319. VLC_DEPENDENCIES += libsidplay2
  320. else
  321. VLC_CONF_OPTS += --disable-sid
  322. endif
  323. ifeq ($(BR2_PACKAGE_LIBTHEORA),y)
  324. VLC_CONF_OPTS += --enable-theora
  325. VLC_DEPENDENCIES += libtheora
  326. else
  327. VLC_CONF_OPTS += --disable-theora
  328. endif
  329. ifeq ($(BR2_PACKAGE_LIBUPNP)$(BR2_PACKAGE_LIBUPNP18),y)
  330. VLC_CONF_OPTS += --enable-upnp
  331. VLC_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBUPNP),libupnp,libupnp18)
  332. else
  333. VLC_CONF_OPTS += --disable-upnp
  334. endif
  335. # libva support depends on ffmpeg
  336. ifeq ($(BR2_PACKAGE_FFMPEG)$(BR2_PACKAGE_LIBVA),yy)
  337. VLC_CONF_OPTS += --enable-libva
  338. VLC_DEPENDENCIES += libva
  339. else
  340. VLC_CONF_OPTS += --disable-libva
  341. endif
  342. ifeq ($(BR2_PACKAGE_LIBVNCSERVER),y)
  343. VLC_CONF_OPTS += --enable-vnc
  344. VLC_DEPENDENCIES += libvncserver
  345. else
  346. VLC_CONF_OPTS += --disable-vnc
  347. endif
  348. ifeq ($(BR2_PACKAGE_LIBVORBIS),y)
  349. VLC_CONF_OPTS += --enable-vorbis
  350. VLC_DEPENDENCIES += libvorbis
  351. else
  352. VLC_CONF_OPTS += --disable-vorbis
  353. endif
  354. ifeq ($(BR2_PACKAGE_LIBV4L),y)
  355. VLC_CONF_OPTS += --enable-v4l2
  356. VLC_DEPENDENCIES += libv4l
  357. else
  358. VLC_CONF_OPTS += --disable-v4l2
  359. endif
  360. ifeq ($(BR2_PACKAGE_LIBVPX),y)
  361. VLC_CONF_OPTS += --enable-vpx
  362. VLC_DEPENDENCIES += libvpx
  363. else
  364. VLC_CONF_OPTS += --disable-vpx
  365. endif
  366. ifeq ($(BR2_PACKAGE_LIBXCB),y)
  367. VLC_CONF_OPTS += --enable-xcb
  368. VLC_DEPENDENCIES += libxcb
  369. else
  370. VLC_CONF_OPTS += --disable-xcb
  371. endif
  372. ifeq ($(BR2_PACKAGE_LIBXML2),y)
  373. VLC_CONF_OPTS += --enable-libxml2
  374. VLC_DEPENDENCIES += libxml2
  375. else
  376. VLC_CONF_OPTS += --disable-libxml2
  377. endif
  378. ifeq ($(BR2_PACKAGE_LIVE555),y)
  379. VLC_CONF_OPTS += --enable-live555
  380. VLC_DEPENDENCIES += live555
  381. ifneq ($(BR2_PACKAGE_OPENSSL),y)
  382. VLC_CONF_ENV += CXXFLAGS="$(TARGET_CXXFLAGS) -DNO_OPENSSL"
  383. endif
  384. else
  385. VLC_CONF_OPTS += --disable-live555
  386. endif
  387. ifeq ($(BR2_PACKAGE_LUA),y)
  388. VLC_CONF_OPTS += --enable-lua
  389. VLC_DEPENDENCIES += lua host-lua
  390. else
  391. VLC_CONF_OPTS += --disable-lua
  392. endif
  393. ifeq ($(BR2_PACKAGE_MINIZIP),y)
  394. VLC_DEPENDENCIES += minizip
  395. endif
  396. ifeq ($(BR2_PACKAGE_MPG123),y)
  397. VLC_CONF_OPTS += --enable-mpg123
  398. VLC_DEPENDENCIES += mpg123
  399. else
  400. VLC_CONF_OPTS += --disable-mpg123
  401. endif
  402. ifeq ($(BR2_PACKAGE_MUSEPACK),y)
  403. VLC_CONF_OPTS += --enable-mpc
  404. VLC_DEPENDENCIES += musepack
  405. else
  406. VLC_CONF_OPTS += --disable-mpc
  407. endif
  408. ifeq ($(BR2_PACKAGE_NCURSES_WCHAR),y)
  409. VLC_CONF_OPTS += --enable-ncurses
  410. VLC_DEPENDENCIES += ncurses
  411. else
  412. VLC_CONF_OPTS += --disable-ncurses
  413. endif
  414. ifeq ($(BR2_PACKAGE_PULSEAUDIO),y)
  415. VLC_CONF_OPTS += --enable-pulse
  416. VLC_DEPENDENCIES += pulseaudio
  417. else
  418. VLC_CONF_OPTS += --disable-pulse
  419. endif
  420. ifeq ($(BR2_PACKAGE_QT5BASE_WIDGETS)$(BR2_PACKAGE_QT5SVG),yy)
  421. VLC_CONF_OPTS += --enable-qt
  422. VLC_DEPENDENCIES += qt5base qt5svg
  423. ifeq ($(BR2_PACKAGE_XLIB_LIBXEXT)$(BR2_PACKAGE_XLIB_LIBXINERAMA)$(BR2_PACKAGE_XLIB_LIBXPM),yyy)
  424. VLC_CONF_OPTS += --enable-skins2
  425. VLC_DEPENDENCIES += xlib_libXext xlib_libXinerama xlib_libXpm
  426. else
  427. VLC_CONF_OPTS += --disable-skins2
  428. endif
  429. else
  430. VLC_CONF_OPTS += --disable-qt --disable-skins2
  431. endif
  432. ifeq ($(BR2_PACKAGE_SDL_IMAGE),y)
  433. VLC_CONF_OPTS += --enable-sdl-image
  434. VLC_DEPENDENCIES += sdl_image
  435. else
  436. VLC_CONF_OPTS += --disable-sdl-image
  437. endif
  438. ifeq ($(BR2_PACKAGE_SAMBA4),y)
  439. VLC_CONF_OPTS += --enable-smbclient
  440. VLC_DEPENDENCIES += samba4
  441. else
  442. VLC_CONF_OPTS += --disable-smbclient
  443. endif
  444. ifeq ($(BR2_PACKAGE_SPEEX)$(BR2_PACKAGE_SPEEXDSP),yy)
  445. VLC_CONF_OPTS += --enable-speex
  446. VLC_DEPENDENCIES += speex speexdsp
  447. else
  448. VLC_CONF_OPTS += --disable-speex
  449. endif
  450. ifeq ($(BR2_PACKAGE_TAGLIB),y)
  451. VLC_CONF_OPTS += --enable-taglib
  452. VLC_DEPENDENCIES += taglib
  453. else
  454. VLC_CONF_OPTS += --disable-taglib
  455. endif
  456. ifeq ($(BR2_PACKAGE_TREMOR),y)
  457. VLC_CONF_OPTS += --enable-tremor
  458. VLC_DEPENDENCIES += tremor
  459. else
  460. VLC_CONF_OPTS += --disable-tremor
  461. endif
  462. ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
  463. VLC_CONF_OPTS += --enable-udev
  464. VLC_DEPENDENCIES += udev
  465. else
  466. VLC_CONF_OPTS += --disable-udev
  467. endif
  468. ifeq ($(BR2_PACKAGE_WAYLAND)$(BR2_PACKAGE_WAYLAND_PROTOCOLS),yy)
  469. VLC_CONF_OPTS += --enable-wayland
  470. VLC_DEPENDENCIES += wayland wayland-protocols
  471. else
  472. VLC_CONF_OPTS += --disable-wayland
  473. endif
  474. ifeq ($(BR2_PACKAGE_X264),y)
  475. VLC_CONF_OPTS += --enable-x264
  476. VLC_DEPENDENCIES += x264
  477. else
  478. VLC_CONF_OPTS += --disable-x264
  479. endif
  480. ifeq ($(BR2_PACKAGE_X265),y)
  481. VLC_CONF_OPTS += --enable-x265
  482. VLC_DEPENDENCIES += x265
  483. else
  484. VLC_CONF_OPTS += --disable-x265
  485. endif
  486. ifeq ($(BR2_PACKAGE_XCB_UTIL_KEYSYMS),y)
  487. VLC_DEPENDENCIES += xcb-util-keysyms
  488. endif
  489. ifeq ($(BR2_PACKAGE_XLIB_LIBX11),y)
  490. VLC_CONF_OPTS += --with-x
  491. VLC_DEPENDENCIES += xlib_libX11
  492. else
  493. VLC_CONF_OPTS += --without-x
  494. endif
  495. ifeq ($(BR2_PACKAGE_ZLIB),y)
  496. VLC_DEPENDENCIES += zlib
  497. endif
  498. ifeq ($(BR2_PACKAGE_GNUTLS),y)
  499. VLC_CONF_OPTS += --enable-gnutls
  500. VLC_DEPENDENCIES += gnutls
  501. else
  502. VLC_CONF_OPTS += --disable-gnutls
  503. endif
  504. $(eval $(autotools-package))