unixodbc.mk 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. ################################################################################
  2. #
  3. # unixodbc
  4. #
  5. ################################################################################
  6. UNIXODBC_VERSION = 2.3.9
  7. UNIXODBC_SOURCE = unixODBC-$(UNIXODBC_VERSION).tar.gz
  8. UNIXODBC_SITE = ftp://ftp.unixodbc.org/pub/unixODBC
  9. UNIXODBC_INSTALL_STAGING = YES
  10. UNIXODBC_LICENSE = LGPL-2.1+ (library), GPL-2.0+ (programs)
  11. UNIXODBC_LICENSE_FILES = COPYING exe/COPYING
  12. UNIXODBC_CONF_OPTS = --enable-drivers --enable-driver-conf
  13. ifeq ($(BR2_PACKAGE_LIBEDIT),y)
  14. UNIXODBC_CONF_OPTS += --enable-editline
  15. UNIXODBC_DEPENDENCIES += libedit
  16. else
  17. UNIXODBC_CONF_OPTS += --disable-editline
  18. endif
  19. ifeq ($(BR2_PACKAGE_LIBICONV),y)
  20. UNIXODBC_CONF_OPTS += --enable-iconv
  21. UNIXODBC_DEPENDENCIES += libiconv
  22. else
  23. UNIXODBC_CONF_OPTS += --disable-iconv
  24. endif
  25. ifeq ($(BR2_PACKAGE_LIBTOOL),y)
  26. UNIXODBC_CONF_OPTS += --without-included-ltdl
  27. UNIXODBC_DEPENDENCIES += libtool
  28. else
  29. UNIXODBC_CONF_OPTS += --with-included-ltdl
  30. endif
  31. ifeq ($(BR2_PACKAGE_READLINE),y)
  32. UNIXODBC_CONF_OPTS += --enable-readline
  33. UNIXODBC_DEPENDENCIES += readline
  34. else
  35. UNIXODBC_CONF_OPTS += --disable-readline
  36. endif
  37. ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
  38. UNIXODBC_CONF_OPTS += --enable-threads
  39. else
  40. UNIXODBC_CONF_OPTS += --disable-threads
  41. endif
  42. $(eval $(autotools-package))