uacme.mk 1.0 KB

123456789101112131415161718192021222324252627282930313233343536
  1. ################################################################################
  2. #
  3. # uacme
  4. #
  5. ################################################################################
  6. UACME_VERSION = 1.4.1
  7. # Released versions are on branch upstream/latest, tagged as
  8. # upstream/X.Y.Z Do not use vX.Y.Z tags from master, as they do not
  9. # include .tarball-version
  10. UACME_SITE = $(call github,ndilieto,uacme,upstream/$(UACME_VERSION))
  11. UACME_LICENSE = GPL-3.0+
  12. UACME_LICENSE_FILES = COPYING
  13. UACME_DEPENDENCIES = libcurl
  14. UACME_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99'
  15. ifeq ($(BR2_PACKAGE_GNUTLS),y)
  16. UACME_CONF_OPTS += --with-gnutls
  17. UACME_DEPENDENCIES += gnutls
  18. else ifeq ($(BR2_PACKAGE_OPENSSL),y)
  19. UACME_CONF_OPTS += --with-openssl
  20. UACME_DEPENDENCIES += openssl
  21. else ifeq ($(BR2_PACKAGE_MBEDTLS),y)
  22. UACME_CONF_OPTS += --with-mbedtls
  23. UACME_DEPENDENCIES += mbedtls
  24. endif
  25. ifeq ($(BR2_PACKAGE_UACME_UALPN),y)
  26. UACME_DEPENDENCIES += libev
  27. UACME_CONF_OPTS += --with-ualpn
  28. else
  29. UACME_CONF_OPTS += --without-ualpn
  30. endif
  31. $(eval $(autotools-package))